dev-python/pytest-describe: Bump to 1.0.0
authorMichał Górny <mgorny@gentoo.org>
Wed, 29 Apr 2020 11:17:30 +0000 (13:17 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 29 Apr 2020 11:18:07 +0000 (13:18 +0200)
Closes: https://bugs.gentoo.org/719992
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-describe/Manifest
dev-python/pytest-describe/pytest-describe-1.0.0.ebuild [new file with mode: 0644]

index eda2cbd4f1515006b17c99da3b9f327d046fc5bd..bdb57c925405caede301f6c40ca8fa46d0fc895b 100644 (file)
@@ -1 +1,2 @@
 DIST pytest-describe-0.11.1.tar.gz 7226 BLAKE2B 5cbe722d1187fa67424e5c932eee7fc90335e6811d7493372515b44d4210d0de4b4d8f33f1583ac1ae400d91d9fb9795b2952a56fc6c2865ab450af279e45c09 SHA512 0634f17ca36f8fa346a6001338827d70dda410376660f370ba04b8857d37e009c5e33f06baee51d1c23a13094c88850668028f5d44a09c31b40baff0bfdaf1ef
+DIST pytest-describe-1.0.0.tar.gz 8917 BLAKE2B 8608a00151273ebb22da6a297580295abbd64c7d9e90bfba9611eac3be64247be20ee43bb64ead1a3f74e65719112a94535506f4402cb7084802360609ab0173 SHA512 1cefa2911e598063b3b9dce381750d204c925cb0dde890b79745c8b4f1cf6d0349f85dc9eaf895000a6f15f45a84fb920f27c01b0af1959125fbe3716cbebbbc
diff --git a/dev-python/pytest-describe/pytest-describe-1.0.0.ebuild b/dev-python/pytest-describe/pytest-describe-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..30f9e69
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Describe-style plugin for pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-describe
+       https://pypi.org/project/pytest-describe"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]"
+BDEPEND="
+       test? ( ${RDEPEND} )"
+
+python_test() {
+       # We need to disable some plugins because tests don't like unexpected
+       # output
+       PYTEST_ADDOPTS="-p no:flaky -p no:capturelog" pytest -vv ||
+               die "Tests failed under ${EPYTHON}"
+}