dev-tex/pythontex: clean old
authorAndrey Grozin <grozin@gentoo.org>
Sat, 22 Feb 2020 08:21:32 +0000 (15:21 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Sat, 22 Feb 2020 08:21:32 +0000 (15:21 +0700)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
dev-tex/pythontex/Manifest
dev-tex/pythontex/pythontex-0.16.ebuild [deleted file]

index 42092217ab3717b04406b4b710fd8bbdd0d4eb33..df4fd95cc1ce51070ff5caaf3845ff49134df3a2 100644 (file)
@@ -1,2 +1 @@
-DIST pythontex-0.16.tar.gz 1787147 BLAKE2B b7b765fdf681f6a757d5dc14437ae433f8310d18ad9e2efe95a8853eaf9f53e2925d7f9e45e0393eb2720019270187fb400e7a6754f18015c4ce5db8a9280729 SHA512 9a84fd7b7f568308addf9ba01c46fadfaface54b9d484c766831f1048064288fd1ecb5c56774bb0041d8f5705f8d5f8a9cd7258dc33157467eca7b3c70259183
 DIST pythontex-0.17.tar.gz 1800631 BLAKE2B 5c4ab31ccd890ca708142e83d047a46d704d2eaead611521a9f272f7a63cfb4016b991741c0338b1874d8cd2949c83b9c5ab59c3004e26540c171666a4f05e63 SHA512 ac248579f8645c225839ca9698b6193d2a7d8360a50e9a8406fae5616f54418a173635d1c2e8c47b18e85cdd1fa1e81c9435169c44f06fb19505c280f9bbaee5
diff --git a/dev-tex/pythontex/pythontex-0.16.ebuild b/dev-tex/pythontex/pythontex-0.16.ebuild
deleted file mode 100644 (file)
index 267d1e5..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit latex-package python-r1
-
-DESCRIPTION="Fast Access to Python from within LaTeX"
-HOMEPAGE="https://github.com/gpoore/pythontex"
-SRC_URI="https://github.com/gpoore/pythontex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="LPPL-1.3 BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="highlighting"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
-       >=dev-texlive/texlive-latexextra-2016
-       dev-tex/pgf"
-RDEPEND="${DEPEND}
-       dev-python/pygments[${PYTHON_USEDEP}]"
-
-TEXMF=/usr/share/texmf-site
-
-src_compile() {
-       cd ${PN} || die
-       rm ${PN}.sty || die
-       VARTEXFONTS="${T}/fonts" latex ${PN}.ins extra || die
-}
-
-src_install() {
-       dodoc ${PN}/README "${S}"/*rst ${PN}_quickstart/*
-
-       cd ${PN} || die
-
-       installation() {
-               python_domodule {de,}${PN}3.py
-               python_domodule ${PN}_{engines,utils}.py
-               python_doscript {de,}${PN}.py syncpdb.py
-               python_optimize
-       }
-       python_foreach_impl installation
-
-       latex-package_src_doinstall dtx ins sty
-}