sci-libs/tensorflow: replace python_export with python_get_sitedir
authorJason Zaman <perfinion@gentoo.org>
Sun, 29 Mar 2020 23:51:42 +0000 (07:51 +0800)
committerJason Zaman <perfinion@gentoo.org>
Tue, 7 Apr 2020 03:04:48 +0000 (11:04 +0800)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
sci-libs/tensorflow/tensorflow-1.15.0.ebuild
sci-libs/tensorflow/tensorflow-2.0.0.ebuild
sci-libs/tensorflow/tensorflow-2.1.0.ebuild
sci-libs/tensorflow/tensorflow-2.2.0_rc2.ebuild

index 7844e3a1a28b66a708552ed2b011e4453f5c887f..8190ff5d464a6cdf478beffc19b4ec202865da75 100644 (file)
@@ -189,9 +189,8 @@ src_configure() {
                export TF_SET_ANDROID_WORKSPACE=0
 
                if use python; then
-                       python_export PYTHON_SITEDIR
                        export PYTHON_BIN_PATH="${PYTHON}"
-                       export PYTHON_LIB_PATH="${PYTHON_SITEDIR}"
+                       export PYTHON_LIB_PATH="$(python_get_sitedir)"
                else
                        export PYTHON_BIN_PATH="$(which python)"
                        export PYTHON_LIB_PATH="$(python -c 'from distutils.sysconfig import *; print(get_python_lib())')"
@@ -320,9 +319,8 @@ src_install() {
                esetup.py install
 
                # libtensorflow_framework.so is in /usr/lib already
-               python_export PYTHON_SITEDIR PYTHON_SCRIPTDIR
-               rm -f "${D}/${PYTHON_SITEDIR}"/${PN}/lib${PN}_framework.so* || die
-               rm -f "${D}/${PYTHON_SITEDIR}"/${PN}_core/lib${PN}_framework.so* || die
+               rm -f "${D}/$(python_get_sitedir)"/${PN}/lib${PN}_framework.so* || die
+               rm -f "${D}/$(python_get_sitedir)"/${PN}_core/lib${PN}_framework.so* || die
                python_optimize
        }
 
index 902eac64ba84d9ed6300d873ccb368ab7a085f25..4e04d4e51c6dbbe7e61e237f84aaf2404b7fbd61 100644 (file)
@@ -188,9 +188,8 @@ src_configure() {
                export TF_SET_ANDROID_WORKSPACE=0
 
                if use python; then
-                       python_export PYTHON_SITEDIR
                        export PYTHON_BIN_PATH="${PYTHON}"
-                       export PYTHON_LIB_PATH="${PYTHON_SITEDIR}"
+                       export PYTHON_LIB_PATH="$(python_get_sitedir)"
                else
                        export PYTHON_BIN_PATH="$(which python)"
                        export PYTHON_LIB_PATH="$(python -c 'from distutils.sysconfig import *; print(get_python_lib())')"
@@ -319,9 +318,8 @@ src_install() {
                esetup.py install
 
                # libtensorflow_framework.so is in /usr/lib already
-               python_export PYTHON_SITEDIR PYTHON_SCRIPTDIR
-               rm -f "${D}/${PYTHON_SITEDIR}"/${PN}/lib${PN}_framework.so* || die
-               rm -f "${D}/${PYTHON_SITEDIR}"/${PN}_core/lib${PN}_framework.so* || die
+               rm -f "${D}/$(python_get_sitedir)"/${PN}/lib${PN}_framework.so* || die
+               rm -f "${D}/$(python_get_sitedir)"/${PN}_core/lib${PN}_framework.so* || die
                python_optimize
        }
 
index ff79ebeaaeb438d82da26b743572eb886e3b205a..4f7b9c8ecf7d09924ca427d0c76be0a18fccc10f 100644 (file)
@@ -194,9 +194,8 @@ src_configure() {
                export TF_SET_ANDROID_WORKSPACE=0
 
                if use python; then
-                       python_export PYTHON_SITEDIR
                        export PYTHON_BIN_PATH="${PYTHON}"
-                       export PYTHON_LIB_PATH="${PYTHON_SITEDIR}"
+                       export PYTHON_LIB_PATH="$(python_get_sitedir)"
                else
                        export PYTHON_BIN_PATH="$(which python)"
                        export PYTHON_LIB_PATH="$(python -c 'from distutils.sysconfig import *; print(get_python_lib())')"
@@ -326,9 +325,8 @@ src_install() {
                esetup.py install
 
                # libtensorflow_framework.so is in /usr/lib already
-               python_export PYTHON_SITEDIR PYTHON_SCRIPTDIR
-               rm -f "${D}/${PYTHON_SITEDIR}"/${PN}/lib${PN}_framework.so* || die
-               rm -f "${D}/${PYTHON_SITEDIR}"/${PN}_core/lib${PN}_framework.so* || die
+               rm -f "${D}/$(python_get_sitedir)"/${PN}/lib${PN}_framework.so* || die
+               rm -f "${D}/$(python_get_sitedir)"/${PN}_core/lib${PN}_framework.so* || die
                python_optimize
        }
 
index 019244a3ce2ae3433f4aa8f30c8ae39370546d54..c0ab709f7b9d158f04b18489726db4930b25fb9a 100644 (file)
@@ -196,9 +196,8 @@ src_configure() {
                export TF_SET_ANDROID_WORKSPACE=0
 
                if use python; then
-                       python_export PYTHON_SITEDIR
                        export PYTHON_BIN_PATH="${PYTHON}"
-                       export PYTHON_LIB_PATH="${PYTHON_SITEDIR}"
+                       export PYTHON_LIB_PATH="$(python_get_sitedir)"
                else
                        export PYTHON_BIN_PATH="$(which python)"
                        export PYTHON_LIB_PATH="$(python -c 'from distutils.sysconfig import *; print(get_python_lib())')"
@@ -327,9 +326,8 @@ src_install() {
                esetup.py install
 
                # libtensorflow_framework.so is in /usr/lib already
-               python_export PYTHON_SITEDIR PYTHON_SCRIPTDIR
-               rm -f "${D}/${PYTHON_SITEDIR}"/${PN}/lib${PN}_framework.so* || die
-               rm -f "${D}/${PYTHON_SITEDIR}"/${PN}_core/lib${PN}_framework.so* || die
+               rm -f "${D}/$(python_get_sitedir)"/${PN}/lib${PN}_framework.so* || die
+               rm -f "${D}/$(python_get_sitedir)"/${PN}_core/lib${PN}_framework.so* || die
                python_optimize
        }