net-firewall/nftables-0.9.4-r1: revbump, call python_optimize, fix deps
authorPatrick McLean <chutzpah@gentoo.org>
Tue, 7 Apr 2020 06:56:06 +0000 (23:56 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Tue, 7 Apr 2020 06:56:06 +0000 (23:56 -0700)
Call python_optimize to fix QA warning about unoptimized python code.

The docbook2X dep is only needed for building man pages, so put it under
the doc USE flag.

Fix the pkg_postinst message about systemd (bug #705308)

Closes: https://bugs.gentoo.org/705308
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
net-firewall/nftables/nftables-0.9.4-r1.ebuild [moved from net-firewall/nftables/nftables-0.9.4.ebuild with 95% similarity]

similarity index 95%
rename from net-firewall/nftables/nftables-0.9.4.ebuild
rename to net-firewall/nftables/nftables-0.9.4-r1.ebuild
index 1858322697d30312bd97c162698e1718260b6824..c6c7496044cf3b472163487878f88976d8aa6448 100644 (file)
@@ -30,8 +30,10 @@ RDEPEND="
 DEPEND="${RDEPEND}"
 
 BDEPEND="
-       doc? ( app-text/asciidoc )
-       >=app-text/docbook2X-0.8.8-r4
+       doc? (
+               app-text/asciidoc
+               >=app-text/docbook2X-0.8.8-r4
+       )
        sys-devel/bison
        sys-devel/flex
        virtual/pkgconfig
@@ -115,6 +117,7 @@ src_install() {
                python_foreach_impl python_make install
        fi
 
+       python_foreach_impl python_optimize
        find "${ED}" -type f -name "*.la" -delete || die
 }
 
@@ -136,7 +139,7 @@ pkg_postinst() {
 
        elog "If you wish to enable the firewall rules on boot (on systemd) you"
        elog "will need to enable the nftables-restore service."
-       elog "    'systemd_enable_service basic.target ${PN}-restore.service'"
+       elog "    'systemctl enable ${PN}-restore.service'"
        elog
        elog "If you are creating firewall rules before the next system restart "
        elog "the nftables-restore service must be manually started in order to "