dev-util/gource: version bump 0.51
authorMichael Palimaka <kensington@gentoo.org>
Mon, 25 Nov 2019 10:33:10 +0000 (21:33 +1100)
committerMichael Palimaka <kensington@gentoo.org>
Mon, 25 Nov 2019 10:33:21 +0000 (21:33 +1100)
Package-Manager: Portage-2.3.76, Repoman-2.3.18
Signed-off-by: Michael Palimaka <kensington@gentoo.org>
dev-util/gource/Manifest
dev-util/gource/gource-0.51.ebuild [new file with mode: 0644]

index 1ed66d04d7a0a7a787840e0988ed79dbd2a7ea2b..46762be358e14027d4602dc2daa0c65606939255 100644 (file)
@@ -1 +1,2 @@
 DIST gource-0.49.tar.gz 874349 BLAKE2B b7d24f415944921deb7df33be4e9918291f5df6dd4813bf98727894e0192b881a583a1dacec2d6e8f2d1a0d6b644bc3b735ef8d7c0b7882d77bcd80913fe08c5 SHA512 cb3482dd06cf38bd775f2ac4b8f3bee78e480dd51e37527024df6e59d6e613290297d65e167a21364aa6251eff78a50ecc8a5fd3772a6e9a4ad22ca21b4b615e
+DIST gource-0.51.tar.gz 882783 BLAKE2B 86a95a55ef9e1ec50e19a4859163d7cdc2733b7c55a68e4d2db493e4c6587682b900b2c73525131972da4dde9fc4d9fa41ba728bdc56fd46fc6a559cb4d837f0 SHA512 f29326ffb2aa6f645fb941e08e41f0cbf8dd894d5a4d607b782caeb12a24e6446198027060b880e0ad14a36efbed19023620dd8c890cfc0c027fc90ac2d5be24
diff --git a/dev-util/gource/gource-0.51.ebuild b/dev-util/gource/gource-0.51.ebuild
new file mode 100644 (file)
index 0000000..a1e9aa5
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="A software version control visualization tool"
+HOMEPAGE="https://gource.io/"
+SRC_URI="https://github.com/acaudwell/Gource/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+       >=dev-libs/boost-1.46:=[threads(+)]
+       >=media-libs/glew-1.5:0=
+       >=media-libs/libpng-1.2:0=
+       media-libs/libsdl2[video,opengl,X]
+       media-libs/sdl2-image[jpeg,png]
+       dev-libs/libpcre:3
+       dev-libs/tinyxml
+       media-libs/freetype:2
+       media-libs/mesa[X(+)]
+       virtual/glu:0
+"
+RDEPEND="${COMMON_DEPEND}
+       media-fonts/freefont
+"
+DEPEND="${COMMON_DEPEND}
+       >=media-libs/glm-0.9.3
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( README ChangeLog THANKS )
+
+src_configure() {
+       # fix bug #386525
+       # this enables gource to be compiled against dev-libs/tinyxml[stl]
+       if has_version dev-libs/tinyxml[stl]; then
+               append-cppflags -DTIXML_USE_STL;
+       fi
+
+       econf \
+               --enable-ttf-font-dir=/usr/share/fonts/freefont/ \
+               --with-tinyxml
+}