app-office/calcurse: revision bump.
authorPatrice Clement <monsieurp@gentoo.org>
Sun, 26 Aug 2018 14:48:40 +0000 (16:48 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 26 Aug 2018 14:49:02 +0000 (16:49 +0200)
... so as to make Soap happy.

Package-Manager: Portage-2.3.40, Repoman-2.3.9

app-office/calcurse/calcurse-4.3.0-r1.ebuild [new file with mode: 0644]

diff --git a/app-office/calcurse/calcurse-4.3.0-r1.ebuild b/app-office/calcurse/calcurse-4.3.0-r1.ebuild
new file mode 100644 (file)
index 0000000..451271e
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="a text-based calendar and scheduling application"
+HOMEPAGE="https://calcurse.org/"
+SRC_URI="https://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc ~ppc64"
+
+RDEPEND="
+       dev-python/httplib2
+       sys-libs/ncurses:0="
+
+DEPEND="
+       ${RDEPEND}"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-4.2.1-tinfo.patch
+)
+
+# Most tests fail.
+RESTRICT="test"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" econf
+}
+
+src_compile() {
+       multilib-minimal_src_compile
+}
+
+src_install() {
+       multilib-minimal_src_install
+}