net-mail/autorespond: EAPI=7, update HOMEPAGE, SRC_URI
authorWim Muskee <wimmuskee@gmail.com>
Sun, 20 Oct 2019 08:31:54 +0000 (10:31 +0200)
committerRobin H. Johnson <robbat2@gentoo.org>
Sat, 2 Nov 2019 04:44:33 +0000 (21:44 -0700)
Closes: https://bugs.gentoo.org/680400
Bug: https://bugs.gentoo.org/697246
Signed-off-by: Wim Muskee <wimmuskee@gmail.com>
(cherry picked from commit c48af03e838a343654ed4196e30747de3ba033e9)
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/13357

net-mail/autorespond/autorespond-2.0.4.ebuild
net-mail/autorespond/autorespond-2.0.5.ebuild

index 2baa30b392b1def7e88e6b2cb473a1b6b13835f9..94509c8a81be525e01c0b86aee20ee9f6ff520be 100644 (file)
@@ -1,29 +1,22 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-inherit eutils
-
-DEBIAN_PV="1"
-DEBIAN_P="${P/-/_}-${DEBIAN_PV}"
 DESCRIPTION="Autoresponder add on package for qmailadmin"
-HOMEPAGE="http://inter7.com/devel/"
+HOMEPAGE="http://inter7.com/software/"
 SRC_URI="mirror://sourceforge/qmailadmin/${P}.tar.gz
-       mirror://debian/pool/contrib/${PN:0:1}/${PN}/${DEBIAN_P}.diff.gz"
+       mirror://gentoo/${PN}_${PV}-1.diff.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc s390 sh sparc x86"
-IUSE=""
 
 RDEPEND="virtual/qmail"
-DEPEND=""
-
-src_unpack() {
-       unpack ${P}.tar.gz
-       epatch "${DISTDIR}"/${DEBIAN_P}.diff.gz
-}
+PATCHES=(
+       "${WORKDIR}/autorespond_2.0.4-1.diff"
+)
+DOCS=( README help_message qmail-auto ChangeLog )
 
 src_compile() {
        emake CFLAGS="${CFLAGS}" || die
@@ -32,7 +25,6 @@ src_compile() {
 src_install () {
        into /var/qmail
        dobin autorespond || die "dobin failed"
-       into /usr
-       dodoc README help_message qmail-auto ChangeLog
        doman *.1
+       einstalldocs
 }
index e9589cc91b5066958f0914ea901e2261a3a76c41..813522f4365b475681751ba1e61b5bb3ecc84916 100644 (file)
@@ -1,26 +1,21 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
-
-inherit eutils
+EAPI=7
 
 DESCRIPTION="Autoresponder add on package for qmailadmin"
-HOMEPAGE="http://inter7.com/devel/"
-SRC_URI="http://inter7.com/devel/${P}.tar.gz"
+HOMEPAGE="http://www.inter7.com/software/"
+SRC_URI="http://qmail.ixip.net/download/${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
-IUSE=""
 
 RDEPEND="virtual/qmail"
-DEPEND=""
-
-src_unpack() {
-       unpack ${A}
-       epatch "${FILESDIR}"/${P}-no-include-bounce.patch
-}
+PATCHES=(
+       "${FILESDIR}/${P}-no-include-bounce.patch"
+)
+DOCS=( README help_message qmail-auto )
 
 src_compile() {
        emake CFLAGS="${CFLAGS}" || die
@@ -29,9 +24,8 @@ src_compile() {
 src_install () {
        into /var/qmail
        dobin autorespond || die "dobin failed"
-       into /usr
-       dodoc README help_message qmail-auto #ChangeLog
        doman *.1
+       einstalldocs
 }
 
 pkg_postinst() {