net-libs/openslp: add libressl support
authorJulian Ospald <hasufell@gentoo.org>
Mon, 5 Oct 2015 14:17:28 +0000 (16:17 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Mon, 5 Oct 2015 14:28:25 +0000 (16:28 +0200)
net-libs/openslp/openslp-2.0.0-r1.ebuild [new file with mode: 0644]

diff --git a/net-libs/openslp/openslp-2.0.0-r1.ebuild b/net-libs/openslp/openslp-2.0.0-r1.ebuild
new file mode 100644 (file)
index 0000000..e4f8d64
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools systemd
+
+DESCRIPTION="An open-source implementation of Service Location Protocol"
+HOMEPAGE="http://www.openslp.org/"
+SRC_URI="mirror://sourceforge/openslp/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="libressl"
+RESTRICT="test"
+
+DEPEND="
+       !libressl? ( dev-libs/openssl:0 )
+       libressl? ( dev-libs/libressl )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-2.0.0-cflags.patch
+       eautoreconf
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "make install failed"
+       dodoc AUTHORS FAQ ChangeLog NEWS README* THANKS
+       rm -rfv "${D}"/usr/doc
+       dohtml -r .
+       newinitd "${FILESDIR}"/slpd-init slpd
+       systemd_dounit "${FILESDIR}"/slpd.service
+}