x11-themes/papirus-icon-theme: Version bump (v20200301)
authorMikle Kolyada <zlogene@gentoo.org>
Fri, 6 Mar 2020 10:17:26 +0000 (13:17 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Fri, 6 Mar 2020 10:18:29 +0000 (13:18 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
x11-themes/papirus-icon-theme/Manifest
x11-themes/papirus-icon-theme/papirus-icon-theme-20191009.ebuild
x11-themes/papirus-icon-theme/papirus-icon-theme-20200301.ebuild [new file with mode: 0644]

index 6fff77585c563b0203ee67fc9aefa9224054eb64..207e8c0867696f5155c5d61b723b3842a58aa54c 100644 (file)
@@ -3,3 +3,4 @@ DIST papirus-icon-theme-20191101.tar.gz 20072061 BLAKE2B 457d47e16ce2c4465c8d23e
 DIST papirus-icon-theme-20191201.tar.gz 20576688 BLAKE2B 50edc8609b37728ab70e8d5914c37b7860927e7123905546d52ce83a5b8a0bc5a706a536a9734a0fc875504c49b7036ab832f8f6b2587bb31b83213857651cfa SHA512 2faeeea2f0b3efe9b2f18783d5e081199295e03bda021243460daa28bde701b6f0aefb0fa6ba196bc32f44e4af72b7efadedbc377a56b315c2d1c3519c7934a1
 DIST papirus-icon-theme-20200102.tar.gz 21110348 BLAKE2B b52282b74cbe771212360e170cdb7be972b98a03e0b283078a58ef8838e95b64ba8e010c0eb97d8c9bc54e8a9e5152ea9768628e6acddb41b4e992da9eb521d1 SHA512 63e80ff061657bf6512d3906cae67d24221cdaea70002281fa91c4c8f127a504cac4e1a1afce0da9555ef917d30a390891c7f8d7f6c11064865819b88887a84f
 DIST papirus-icon-theme-20200201.tar.gz 21482791 BLAKE2B 5287e031505835465b85115d1a86e8af61b9e5947357654a3f00b768708bc6e49accbaa219b6b0889798153215cc072d7f8b1cd677fdfff113bf925968980e04 SHA512 07ed45eb409ed12f57657f058f9a5a03dec77679ed598dc8645536a614ecc5424c60be57f10de20ca72204d2a21152fdd62adadf2637bbfa1266d588c787d7e9
+DIST papirus-icon-theme-20200301.tar.gz 21896164 BLAKE2B fb2c11b3ebe893375283e7f95cc6e89a7c8b54f4b2d129a2517a2b4eb5f3c84da925ac399491e0739d16dd6c050c2969420f73dce7c9a2e83522ab7d63299b23 SHA512 8b9f0a9b0fdb676365d6b30af8ba8dee71ff433a4c4317151899f09614da3fc9764e5e9c48743cdf7c8fde6eea53a1d3ab37eb890f1486fc54ce328e6af9b348
index 96967c513d908b28743d73445a4740dcb20faece..688a4a61f1dc26add63e74c7cd7dabb7beadeece 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit gnome2-utils
+inherit gnome2-utils xdg-utils
 
 DESCRIPTION="icon theme for Linux"
 HOMEPAGE="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme"
@@ -22,5 +22,5 @@ src_install() {
 }
 
 pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/x11-themes/papirus-icon-theme/papirus-icon-theme-20200301.ebuild b/x11-themes/papirus-icon-theme/papirus-icon-theme-20200301.ebuild
new file mode 100644 (file)
index 0000000..5d08cbe
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2-utils
+
+DESCRIPTION="icon theme for Linux"
+HOMEPAGE="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme"
+SRC_URI="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() { :; }
+
+src_install() {
+       insinto /usr/share/icons
+       doins -r ePapirus Papirus{,-Dark,-Light}
+
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }