Replacing einfo with ewarn/eerror
authorMarius Mauch <genone@gentoo.org>
Wed, 2 May 2007 00:20:19 +0000 (00:20 +0000)
committerMarius Mauch <genone@gentoo.org>
Wed, 2 May 2007 00:20:19 +0000 (00:20 +0000)
Package-Manager: portage-2.1.2.5

net-dialup/eagle-usb/ChangeLog
net-dialup/eagle-usb/eagle-usb-2.3.3.ebuild

index 632792b62b8d53901ab7dd556444d56ea30b7475..69882c491b01bf114ec30862271967874b06cf6b 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for net-dialup/eagle-usb
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/eagle-usb/ChangeLog,v 1.10 2007/02/25 09:14:08 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/eagle-usb/ChangeLog,v 1.11 2007/05/02 00:20:19 genone Exp $
+
+  02 May 2007; Marius Mauch <genone@gentoo.org> eagle-usb-2.3.3.ebuild:
+  Replacing einfo with ewarn/eerror
 
   25 Feb 2007; <genstef@gentoo.org> eagle-usb-2.3.3.ebuild:
   use KV_DIR only after linux-mod_pkg_setup, bug 168051
index fb340c979b0928a70a1a1fbc69d4e02687f62c9f..b86a19034ce59170f411f2a47d416f3be49ef796 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/eagle-usb/eagle-usb-2.3.3.ebuild,v 1.4 2007/02/25 09:14:08 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/eagle-usb/eagle-usb-2.3.3.ebuild,v 1.5 2007/05/02 00:20:19 genone Exp $
 
 inherit linux-mod eutils
 
@@ -24,9 +24,9 @@ pkg_setup() {
        if kernel_is ge 2 6 16; then
                eerror "This driver should be used only with kernel versions less than 2.6.16."
                eerror "Please install and use the driver included in your kernel instead."
-               echo
-               einfo "The kernel option that enables the driver is CONFIG_USB_UEAGLEATM."
-               einfo "You should also install firmware files available through net-dialup/ueagle-atm."
+               eerror
+               eerror "The kernel option that enables the driver is CONFIG_USB_UEAGLEATM."
+               eerror "You should also install firmware files available through net-dialup/ueagle-atm."
                die "unsupported kernel version"
        fi
        linux-mod_pkg_setup
@@ -69,20 +69,20 @@ pkg_postinst() {
 
        ewarn "Please set METHOD in /etc/conf.d/${PN} to the needed value:"
        ewarn "dhcpip:"
-       einfo "          Make sure you have dhcpcd emerged."
+       ewarn "          Make sure you have dhcpcd emerged."
        ewarn "staticip:"
-       einfo "          Set your static IP in /etc/conf.d/eagle-adsl"
+       ewarn "          Set your static IP in /etc/conf.d/eagle-adsl"
        ewarn "dhcpip && staticip: You can use the following to set up the eagle conf-files:"
-       echo 'sed -i -e "s/Encapsulation *= *[0-9]\+/Encapsulation=00000004/" /etc/eagle-usb/eagle-usb.conf'
-       echo 'sed -i -e "s/VCI *= *[0-9]\+/VCI=00000024/" /etc/eagle-usb/eagle-usb.conf'
+       ewarn 'sed -i -e "s/Encapsulation *= *[0-9]\+/Encapsulation=00000004/" /etc/eagle-usb/eagle-usb.conf'
+       ewarn 'sed -i -e "s/VCI *= *[0-9]\+/VCI=00000024/" /etc/eagle-usb/eagle-usb.conf'
        ewarn "pppoa:"
-       einfo "          Make sure you have kernel support for HDCL and PPP"
-       einfo "          Edit /etc/ppp/peers/dsl.peer to insert your username as"
-       einfo "          well as /etc/ppp/chap-secrets and /etc/ppp/pap-secrets"
-       einfo
-       einfo "          dsl.peer contains the \"usepeerdns\" option so, you"
-       einfo "          should consider making a symlink named /etc/resolv.conf"
-       einfo "          and pointing to /etc/ppp/resolv.conf:"
-       echo "rm /etc/resolv.conf"
-       echo "ln -s /etc/ppp/resolv.conf /etc/resolv.conf"
+       ewarn "          Make sure you have kernel support for HDCL and PPP"
+       ewarn "          Edit /etc/ppp/peers/dsl.peer to insert your username as"
+       ewarn "          well as /etc/ppp/chap-secrets and /etc/ppp/pap-secrets"
+       ewarn
+       ewarn "          dsl.peer contains the \"usepeerdns\" option so, you"
+       ewarn "          should consider making a symlink named /etc/resolv.conf"
+       ewarn "          and pointing to /etc/ppp/resolv.conf:"
+       ewarn "rm /etc/resolv.conf"
+       ewarn "ln -s /etc/ppp/resolv.conf /etc/resolv.conf"
 }