dev-python/argcomplete: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 11:03:57 +0000 (13:03 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 12:58:25 +0000 (14:58 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild

index a05a6d23449cb4a2f798a7e0c076f1d7e9c7022c..40f14756ab33d44c7ecc937360d4010c07714243 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6..9}} pypy3 )
 
 inherit distutils-r1
 
@@ -23,7 +23,6 @@ RDEPEND="
        ' -2 python3_{5,6,7} pypy3)"
 # pip is called as an external tool
 BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                app-shells/fish
                app-shells/tcsh