www-client/epiphany: bump to 3.30.0 and p.masked 3.30.1
authorMart Raudsepp <leio@gentoo.org>
Sat, 6 Oct 2018 18:07:29 +0000 (21:07 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sat, 6 Oct 2018 18:36:42 +0000 (21:36 +0300)
The MSE enabling in 3.30.1 to fix having Youtube playback for over 360p
is crashing hard for me, unable to even look at 240p. So this is package
masked until some more investigations. It's supposed to be experimental,
but just outright crashing sounds bad and I got tired of sitting in
coredumpctl service runs for minutes.

Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11

profiles/package.mask
www-client/epiphany/Manifest
www-client/epiphany/epiphany-3.30.0.ebuild [new file with mode: 0644]
www-client/epiphany/epiphany-3.30.1.ebuild [new file with mode: 0644]

index 78ab889972c3b8e9c1f0f095d24853640f4f7180..ced9ad5651c46c9375b07061591779d1319d9b92 100644 (file)
 
 #--- END OF EXAMPLES ---
 
+# Mart Raudsepp <leio@gentoo.org> (06 Oct 2018)
+# Crashes on Youtube MSE videos, while older versions lack support
+# for higher resolution MSE videos. Pending further investigation.
+=www-client/epiphany-3.30.1
+
 # Thomas Deutschmann <whissi@gentoo.org> (06 Oct 2018)
 # Outdated and vulnerable snapshot; libav-12.3 is the better
 # version for now
index 94cecca6ab10065c534c5bfcb66559e0af4cf37f..ed666f1b49f8cdea5936e5822f77df028e4c38f9 100644 (file)
@@ -1,2 +1,4 @@
 DIST epiphany-3.24.5.tar.xz 3216736 BLAKE2B 8a4dd668606521d1b0144afc9ace8607f52eac457f0059e6087216323ec1132dbe1c755e40dfe9993bf685e5444db1268ada1cdf55edc04c51058fdd256c6047 SHA512 a8f203d182b8c87878a3272f8b4f642b0cf4128476e0727208135cfdffeb293425cf662c58820f0d3aed2e1b20fe6dc4cf5cbb8277a398c6f533a0bea34f40f2
 DIST epiphany-3.26.7.tar.xz 4429308 BLAKE2B cdd8cf084631891e97585307c90bd67f45e71deb6564f54711deb8dfd39c09007732efeb22ad5be45c1b0af6af7be30cf13a9d90aa1e9506a2e997f6f3f8d854 SHA512 686c8825d476a4c6675dadd7a68bf72727714bc6fe01b4dbf67d39b2dc7e3f21d4f630417865800664a716d6316df8a97fde5201ec72c90f448fd6f0af4b49a0
+DIST epiphany-3.30.0.tar.xz 4528508 BLAKE2B 75d605a1117131bebaf0e0a7013ae4e9599b7058e26f4acf84140a6e345255cccac910cc9d5a2f90be0835f7dbaa6c77d16e127dfb5b1ae139ef179a20795444 SHA512 80ba03c67bd467e31e572afd4e8632232bc002c63e584e87bc6c3b74d23cd470f14e696080fd952a8617c6c07202eafff01bc97f72d9a06f0121d75565e667f3
+DIST epiphany-3.30.1.tar.xz 4528876 BLAKE2B 1dbb630128a9af975939d386b3113a41ef92ce1bb756a5407a216fa8f25f1dfcd051a11c54a034aeafd8ca5aa5ada7da83f3ecf825370801b04b10b7ef794c80 SHA512 37d6814d9dfb1f70e6cfd3395179b9e213eb79773c1fed238999d5c6ae34c0b93b6f93dff695eb959cb46e89a2cd6b705c1a294d1424c82137ba26d0b7a37503
diff --git a/www-client/epiphany/epiphany-3.30.0.ebuild b/www-client/epiphany/epiphany-3.30.0.ebuild
new file mode 100644 (file)
index 0000000..b961e6b
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+       >=dev-libs/glib-2.52.0:2
+       >=x11-libs/gtk+-3.22.13:3
+       >=dev-libs/nettle-3.2:=
+       >=net-libs/webkit-gtk-2.21.92:4=
+       >=x11-libs/cairo-1.2
+       >=dev-libs/libdazzle-3.28.0
+       >=app-crypt/gcr-3.5.5:=[gtk]
+       >=x11-libs/gdk-pixbuf-2.36.5:2
+       dev-libs/icu:=
+       >=app-text/iso-codes-0.35
+       >=dev-libs/json-glib-1.2.4
+       >=x11-libs/libnotify-0.5.1
+       >=app-crypt/libsecret-0.14
+       >=net-libs/libsoup-2.48:2.4
+       >=dev-libs/libxml2-2.6.12:2
+       >=dev-libs/libxslt-1.1.7
+       dev-db/sqlite:3
+       dev-libs/gmp:0=
+       >=gnome-base/gsettings-desktop-schemas-0.0.1
+"
+RDEPEND="${COMMON_DEPEND}
+       x11-themes/adwaita-icon-theme
+"
+# paxctl needed for bug #407085
+# appstream-glib needed for appdata.xml gettext translation
+DEPEND="${COMMON_DEPEND}
+       dev-libs/appstream-glib
+       dev-util/gdbus-codegen
+       dev-util/glib-utils
+       dev-util/itstool
+       sys-apps/paxctl
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+src_configure() {
+       local emesonargs=(
+               -Ddeveloper_mode=false
+               -Ddistributor_name=Gentoo
+               -Dtech_preview=false
+               $(meson_use test unit_tests)
+       )
+       meson_src_configure
+}
+
+src_test() {
+       virtx meson_src_test
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_icon_cache_update
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_icon_cache_update
+       gnome2_schemas_update
+}
diff --git a/www-client/epiphany/epiphany-3.30.1.ebuild b/www-client/epiphany/epiphany-3.30.1.ebuild
new file mode 100644 (file)
index 0000000..b961e6b
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+       >=dev-libs/glib-2.52.0:2
+       >=x11-libs/gtk+-3.22.13:3
+       >=dev-libs/nettle-3.2:=
+       >=net-libs/webkit-gtk-2.21.92:4=
+       >=x11-libs/cairo-1.2
+       >=dev-libs/libdazzle-3.28.0
+       >=app-crypt/gcr-3.5.5:=[gtk]
+       >=x11-libs/gdk-pixbuf-2.36.5:2
+       dev-libs/icu:=
+       >=app-text/iso-codes-0.35
+       >=dev-libs/json-glib-1.2.4
+       >=x11-libs/libnotify-0.5.1
+       >=app-crypt/libsecret-0.14
+       >=net-libs/libsoup-2.48:2.4
+       >=dev-libs/libxml2-2.6.12:2
+       >=dev-libs/libxslt-1.1.7
+       dev-db/sqlite:3
+       dev-libs/gmp:0=
+       >=gnome-base/gsettings-desktop-schemas-0.0.1
+"
+RDEPEND="${COMMON_DEPEND}
+       x11-themes/adwaita-icon-theme
+"
+# paxctl needed for bug #407085
+# appstream-glib needed for appdata.xml gettext translation
+DEPEND="${COMMON_DEPEND}
+       dev-libs/appstream-glib
+       dev-util/gdbus-codegen
+       dev-util/glib-utils
+       dev-util/itstool
+       sys-apps/paxctl
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+src_configure() {
+       local emesonargs=(
+               -Ddeveloper_mode=false
+               -Ddistributor_name=Gentoo
+               -Dtech_preview=false
+               $(meson_use test unit_tests)
+       )
+       meson_src_configure
+}
+
+src_test() {
+       virtx meson_src_test
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_icon_cache_update
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_icon_cache_update
+       gnome2_schemas_update
+}