media-plugins/audacious-plugins: Move ewarn to pkg_setup
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 15 Nov 2019 00:04:51 +0000 (01:04 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 15 Nov 2019 00:35:55 +0000 (01:35 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-plugins/audacious-plugins/audacious-plugins-9999.ebuild

index 02a3be387140a90278887da591be2bd8e1c4fd04..940ec18ab531929c50f7f0a95fc0aad5733dda27 100644 (file)
@@ -113,6 +113,10 @@ RDEPEND="${DEPEND}"
 
 S="${WORKDIR}/${MY_P}"
 
+pkg_setup() {
+       use mp3 || ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
+}
+
 src_prepare() {
        default
        if ! use nls; then
@@ -122,8 +126,6 @@ src_prepare() {
 }
 
 src_configure() {
-       use mp3 || ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
-
        local myeconfargs=(
                --enable-mpris2
                --enable-songchange