app-portage/nattka: Initial live ebuild for arch testing tool
authorMichał Górny <mgorny@gentoo.org>
Wed, 1 Apr 2020 13:08:23 +0000 (15:08 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 1 Apr 2020 13:08:23 +0000 (15:08 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/nattka/metadata.xml [new file with mode: 0644]
app-portage/nattka/nattka-9999.ebuild [new file with mode: 0644]

diff --git a/app-portage/nattka/metadata.xml b/app-portage/nattka/metadata.xml
new file mode 100644 (file)
index 0000000..0319eec
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>mgorny@gentoo.org</email>
+               <name>Michał Górny</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/app-portage/nattka/nattka-9999.ebuild b/app-portage/nattka/nattka-9999.ebuild
new file mode 100644 (file)
index 0000000..7b4d254
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="https://github.com/mgorny/nattka/"
+EGIT_REPO_URI="https://github.com/mgorny/nattka.git"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+       dev-python/requests[${PYTHON_USEDEP}]
+       dev-util/pkgcheck[${PYTHON_USEDEP}]
+       sys-apps/pkgcore[${PYTHON_USEDEP}]"
+BDEPEND="
+       test? ( dev-python/vcrpy[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest