www-servers/lighttpd: Version bump (v1.4.53)
authorMikle Kolyada <zlogene@gentoo.org>
Wed, 30 Jan 2019 09:06:51 +0000 (12:06 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Wed, 30 Jan 2019 09:07:28 +0000 (12:07 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

www-servers/lighttpd/Manifest
www-servers/lighttpd/lighttpd-1.4.53.ebuild [new file with mode: 0644]

index 53cce0d910a2708c3850aefcf98f2c760a36c0f9..e8e331119c946b91c99348cc9bea5fffa029822c 100644 (file)
@@ -1,2 +1,3 @@
 DIST lighttpd-1.4.51.tar.xz 723268 BLAKE2B 524874a5cc29b3fad23b1d2d623bcaf5b781556d7f11848047bc02fb4793480acfc5b5eb6f60304be9472a8b42c87e8c23baf85352bc9479ea156c4a03990bad SHA512 ee4f150c30322dae50760b99cddd0bd935195ee21e042809fa8d303425d12081c23c00d8ea8fcd3d023b6b414a46b9b953edc4ed25400fe39f10487f0956561f
 DIST lighttpd-1.4.52.tar.xz 728668 BLAKE2B 6ffce05ad8cb83895f8865cfd2ce627c39c881e7717992ce25d1ed899c51fd1769d91d9c43f621b013e536a3a24d4350e5525426be333aa5b21913f480af5d31 SHA512 3c604f441c001641681b958012524c9a2e801314b07d9741d4b5e086e7585d676516e3fe587e0ff69f1f937c11b9a290f2173866d6b90019117b6be299972a72
+DIST lighttpd-1.4.53.tar.xz 732160 BLAKE2B 75848ab259226fc77b232dfb365c6c656e4605055fb5beba1aea60f54f01cb76c3260ca97e59110dc3dd3d1ba7cb3f2fad646f91f37baee69a8cdbaefcf125a4 SHA512 bf5ea1c9f6f664c9ddcdf33ddba5b2bff760960d03c29a2181e73e3aceb45b523bb90003d0e0bc565334751830e6027cd7be2e92d030cde90813511957c9ea76
diff --git a/www-servers/lighttpd/lighttpd-1.4.53.ebuild b/www-servers/lighttpd/lighttpd-1.4.53.ebuild
new file mode 100644 (file)
index 0000000..aab14ef
--- /dev/null
@@ -0,0 +1,227 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic readme.gentoo-r1 systemd user
+
+DESCRIPTION="Lightweight high-performance web server"
+HOMEPAGE="https://www.lighttpd.net https://github.com/lighttpd"
+SRC_URI="https://download.lighttpd.net/lighttpd/releases-1.4.x/${P}.tar.xz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="bzip2 dbi doc fam gdbm geoip ipv6 kerberos ldap libev libressl lua minimal mmap memcached mysql pcre php postgres rrdtool sasl selinux ssl sqlite test webdav xattr zlib"
+
+REQUIRED_USE="kerberos? ( ssl !libressl ) webdav? ( sqlite )"
+
+BDEPEND="dev-libs/libgamin
+       virtual/pkgconfig"
+
+COMMON_DEPEND="
+       bzip2?    ( app-arch/bzip2 )
+       dbi?    ( dev-db/libdbi )
+       fam?    ( virtual/fam )
+       gdbm?   ( sys-libs/gdbm )
+       geoip?  ( dev-libs/geoip )
+       ldap?   ( >=net-nds/openldap-2.1.26 )
+       libev?  ( >=dev-libs/libev-4.01 )
+       lua?    ( >=dev-lang/lua-5.1:= )
+       memcached? ( dev-libs/libmemcached )
+       mysql?  ( dev-db/mysql-connector-c:= )
+       pcre?   ( >=dev-libs/libpcre-3.1 )
+       php?      ( dev-lang/php:*[cgi] )
+       postgres? ( dev-db/postgresql:* )
+       rrdtool?  ( net-analyzer/rrdtool )
+       sasl?     ( dev-libs/cyrus-sasl )
+       ssl? (
+               !libressl? ( >=dev-libs/openssl-0.9.7:0=[kerberos(-)?] )
+               libressl? ( dev-libs/libressl:= )
+       )
+       sqlite? ( dev-db/sqlite:3 )
+       webdav? (
+               dev-libs/libxml2
+               sys-fs/e2fsprogs
+       )
+       xattr? ( kernel_linux? ( sys-apps/attr ) )
+       zlib? ( >=sys-libs/zlib-1.1 )"
+
+DEPEND="${COMMON_DEPEND}
+       doc?  ( dev-python/docutils )
+       test? (
+               virtual/perl-Test-Harness
+               dev-libs/fcgi
+       )"
+
+RDEPEND="${COMMON_DEPEND}
+       selinux? ( sec-policy/selinux-apache )
+"
+
+# update certain parts of lighttpd.conf based on conditionals
+update_config() {
+       local config="${D}/etc/lighttpd/lighttpd.conf"
+
+       # enable php/mod_fastcgi settings
+       use php && { sed -i -e 's|#.*\(include.*fastcgi.*$\)|\1|' ${config} || die; }
+
+       # enable stat() caching
+       use fam && { sed -i -e 's|#\(.*stat-cache.*$\)|\1|' ${config} || die; }
+
+       # automatically listen on IPv6 if built with USE=ipv6. Bug #234987
+       use ipv6 && { sed -i -e 's|# server.use-ipv6|server.use-ipv6|' ${config} || die; }
+}
+
+# remove non-essential stuff (for USE=minimal)
+remove_non_essential() {
+       local libdir="${D}/usr/$(get_libdir)/${PN}"
+
+       # text docs
+       use doc || rm -fr "${D}"/usr/share/doc/${PF}/txt
+
+       # non-essential modules
+       rm -f \
+               ${libdir}/mod_{compress,evhost,expire,proxy,scgi,secdownload,simple_vhost,status,setenv,trigger*,usertrack}.* || die
+
+       # allow users to keep some based on USE flags
+       use pcre    || rm -f ${libdir}/mod_{ssi,re{direct,write}}.*
+       use webdav  || rm -f ${libdir}/mod_webdav.*
+       use mysql   || rm -f ${libdir}/mod_mysql_vhost.*
+       use lua     || rm -f ${libdir}/mod_{cml,magnet}.*
+       use rrdtool || rm -f ${libdir}/mod_rrdtool.*
+       use zlib    || rm -f ${libdir}/mod_compress.*
+}
+
+pkg_setup() {
+       if ! use pcre ; then
+               ewarn "It is highly recommended that you build ${PN}"
+               ewarn "with perl regular expressions support via USE=pcre."
+               ewarn "Otherwise you lose support for some core options such"
+               ewarn "as conditionals and modules such as mod_re{write,direct}"
+               ewarn "and mod_ssi."
+       fi
+
+       enewgroup lighttpd
+       enewuser lighttpd -1 -1 /var/www/localhost/htdocs lighttpd
+
+       DOC_CONTENTS="IPv6 migration guide:\n
+               http://redmine.lighttpd.net/projects/lighttpd/wiki/IPv6-Config"
+}
+
+src_prepare() {
+       default
+       use memcached && append-ldflags -pthread
+       #dev-python/docutils installs rst2html.py not rst2html
+       sed -i -e 's|\(rst2html\)|\1.py|g' doc/outdated/Makefile.am || \
+               die "sed doc/Makefile.am failed"
+       eautoreconf
+}
+
+src_configure() {
+       econf --libdir=/usr/$(get_libdir)/${PN} \
+               --enable-lfs \
+               $(use_enable ipv6) \
+               $(use_enable mmap) \
+               $(use_with bzip2) \
+               $(use_with dbi) \
+               $(use_with fam) \
+               $(use_with gdbm) \
+               $(use_with geoip ) \
+               $(use_with kerberos krb5) \
+               $(use_with ldap) \
+               $(use_with libev) \
+               $(use_with lua) \
+               $(use_with memcached) \
+               $(use_with mysql) \
+               $(use_with pcre) \
+               $(use_with postgres pgsql) \
+               $(use_with sasl) \
+               $(use_with ssl openssl) \
+               $(use_with sqlite sqlite) \
+               $(use_with webdav webdav-props) \
+               $(use_with webdav webdav-locks) \
+               $(use_with xattr attr) \
+               $(use_with zlib)
+}
+
+src_compile() {
+       emake
+
+       if use doc ; then
+               einfo "Building HTML documentation"
+               cd doc || die
+               emake html
+       fi
+}
+
+src_test() {
+       if [[ ${EUID} -eq 0 ]]; then
+               default_src_test
+       else
+               ewarn "test skipped, please re-run as root if you wish to test ${PN}"
+       fi
+}
+
+src_install() {
+       default
+
+       find "${D}" -name '*.la' -delete || die
+
+       # init script stuff
+       newinitd "${FILESDIR}"/lighttpd.initd lighttpd
+       newconfd "${FILESDIR}"/lighttpd.confd lighttpd
+       use fam && has_version app-admin/fam && \
+               { sed -i 's/after famd/need famd/g' "${D}"/etc/init.d/lighttpd || die; }
+
+       # configs
+       insinto /etc/lighttpd
+       doins "${FILESDIR}"/conf/lighttpd.conf
+       doins "${FILESDIR}"/conf/mime-types.conf
+       doins "${FILESDIR}"/conf/mod_cgi.conf
+       doins "${FILESDIR}"/conf/mod_fastcgi.conf
+
+       # update lighttpd.conf directives based on conditionals
+       update_config
+
+       # docs
+       dodoc AUTHORS README NEWS doc/scripts/*.sh
+       newdoc doc/config//lighttpd.conf lighttpd.conf.distrib
+       use ipv6 && readme.gentoo_create_doc
+
+       use doc && dodoc -r doc
+
+       docinto txt
+       dodoc doc/outdated/*.txt
+
+       # logrotate
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}"/lighttpd.logrotate-r1 lighttpd
+
+       keepdir /var/l{ib,og}/lighttpd /var/www/localhost/htdocs
+       fowners lighttpd:lighttpd /var/l{ib,og}/lighttpd
+       fperms 0750 /var/l{ib,og}/lighttpd
+
+       #spawn-fcgi may optionally be installed via www-servers/spawn-fcgi
+       rm -f "${D}"/usr/bin/spawn-fcgi "${D}"/usr/share/man/man1/spawn-fcgi.* || die
+
+       use minimal && remove_non_essential
+
+       systemd_dounit "${FILESDIR}/${PN}.service"
+       systemd_dotmpfilesd "${FILESDIR}/${PN}.tmpfiles.conf"
+}
+
+pkg_postinst () {
+       use ipv6 && readme.gentoo_print_elog
+
+       if [[ -f ${ROOT}etc/conf.d/spawn-fcgi.conf ]] ; then
+               einfo "spawn-fcgi is now provided by www-servers/spawn-fcgi."
+               einfo "spawn-fcgi's init script configuration is now located"
+               einfo "at /etc/conf.d/spawn-fcgi."
+       fi
+
+       if [[ -f ${ROOT}etc/lighttpd.conf ]] ; then
+               elog "Gentoo has a customized configuration,"
+               elog "which is now located in /etc/lighttpd.  Please migrate your"
+               elog "existing configuration."
+       fi
+}