app-portage/nattka: Bump to 0.2
authorMichał Górny <mgorny@gentoo.org>
Fri, 17 Apr 2020 08:46:33 +0000 (10:46 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 17 Apr 2020 09:07:43 +0000 (11:07 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/nattka/Manifest
app-portage/nattka/nattka-0.2.ebuild [new file with mode: 0644]

index 23a61c78af4301d65f8bb148a697f43b000e7b81..9b9b25ce541abfebe697e3d60d53ef4cc6106170 100644 (file)
@@ -1,2 +1,3 @@
 DIST nattka-0.1.10.tar.gz 77467 BLAKE2B 2f1ccca7bab2db95be2145716ab17a48959ffef4ec41ade2e4d944b66aa1d2bb1146e43089fe75714502ada0510c6257cc1577bda9353c517572e09407f818ae SHA512 8fc3dc8e37e755c5736dd74d0fd081bbce26e5f1093401f527f8818ddf2aebbddf36feb04ca1e76fd37f2cffaecaca768e7f70ac85d0f31bab24b09a12d23cf4
 DIST nattka-0.1.11.tar.gz 80381 BLAKE2B 0de07893bb5517f706fcc37b24466276a1bd9a5a973acb25ed37936f793f0d00a592d14e5b15b5aa16987aea4f2bbe9ad582475adfe89f986c8f75c5a558bcf6 SHA512 fda0a4fc997344e0db5740e9ad6ef683044ae83b1c35d48b218b7274b305057a488944ec75ebe0abcd2f999af716561956ac212a8c1bd49dbd861bcf48419033
+DIST nattka-0.2.tar.gz 83729 BLAKE2B 686c09c03d1edab981799f07397c558bab3c2c9befdeb16e1fbb796b3eeb789cd7efc63369ce5e6a15c60b5f5b71a47074f39e851451971bdba8549175fc4024 SHA512 53a45214455febb266faa70b37782c2c1857ea3e6ec0d07dd6be4822046ee0cfe8af67c143843d292a94df94e65b244d93316a3bb3b44709b08c4a14a9de6455
diff --git a/app-portage/nattka/nattka-0.2.ebuild b/app-portage/nattka/nattka-0.2.ebuild
new file mode 100644 (file)
index 0000000..4f5a648
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="https://github.com/mgorny/nattka/"
+SRC_URI="https://github.com/mgorny/nattka/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+       dev-python/lxml[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       dev-util/pkgcheck[${PYTHON_USEDEP}]
+       dev-vcs/git
+       sys-apps/pkgcore[${PYTHON_USEDEP}]"
+BDEPEND="
+       test? ( dev-python/vcrpy[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+pkg_postinst() {
+       elog "NATTkA can optionally use:"
+       elog "  dev-python/networkx"
+       elog "to sort 'apply' output in dependency order."
+}