dev-libs/libsodium: add support on musl
authorAnthony G. Basile <blueness@gentoo.org>
Sat, 19 Jan 2019 18:36:07 +0000 (13:36 -0500)
committerAnthony G. Basile <blueness@gentoo.org>
Sat, 19 Jan 2019 18:36:07 +0000 (13:36 -0500)
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-libs/libsodium/libsodium-1.0.15-r1.ebuild
dev-libs/libsodium/libsodium-1.0.16-r2.ebuild
dev-libs/libsodium/libsodium-1.0.17.ebuild

index cbf53540a9cff573ebe6a0fd4563a2d16a012ac0..ae0419e4c365322961f65f91c5a9b8b6321afc95 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -26,6 +26,8 @@ src_configure() {
 
        # --disable-pie needed on x86, bug #512734
        use x86 && myconf="${myconf} --disable-pie"
+       # --disable-ssp is needed on musl x86
+       use x86 && use elibc_musl && myconf+="${myconf} --disable-ssp"
 
        econf \
                $(use_enable asm) \
index 393a0f21ab8e6a45318aa09416c5fcbb6abc4b7f..fe6573407753aaf9078143ccf6dc360b3f39346d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -28,6 +28,10 @@ multilib_src_configure() {
        # --disable-pie is needed on x86, see bug #512734
        if [[ "${MULTILIB_ABI_FLAG}" == "abi_x86_32" ]]; then
                myconf="${myconf} --disable-pie"
+               # --disable-ssp is needed on musl x86
+               if use elibc_musl; then
+                       myconf+="${myconf} --disable-ssp"
+               fi
        fi
 
        econf \
index dcfe073f5754b667dac2bd79fc0ee97756cc2cbf..ca8df8c8f25f4710bed9be3d6a5547ca52f95a84 100644 (file)
@@ -34,6 +34,10 @@ multilib_src_configure() {
        # --disable-pie is needed on x86, see bug #512734
        if [[ "${MULTILIB_ABI_FLAG}" == "abi_x86_32" ]]; then
                myeconfargs+=( --disable-pie )
+               # --disable-ssp is needed on musl x86
+               if use elibc_musl; then
+                       myeconfargs+=( --disable-ssp )
+               fi
        fi
 
        ECONF_SOURCE="${S}" econf ${myeconfargs[@]}