virtual/service-manager: use prefix-guest to draw baselayout-prefix.
authorBenda Xu <heroxbd@gentoo.org>
Tue, 20 Aug 2019 09:08:44 +0000 (17:08 +0800)
committerBenda Xu <heroxbd@gentoo.org>
Thu, 19 Sep 2019 12:11:33 +0000 (20:11 +0800)
  Now prefix-guest is used to represent prefix-rpath.  Only in that case
  baselayout-prefix is needed.  Otherwise, prefix uses the same set of
  package as vanilla Gentoo.

  prefix-guest is only an implicit USE flag, so remove it from IUSE.

  Bump to version 1 and EAPI 7.

Closes: https://bugs.gentoo.org/692592
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
virtual/service-manager/service-manager-1.ebuild [new file with mode: 0644]

diff --git a/virtual/service-manager/service-manager-1.ebuild b/virtual/service-manager/service-manager-1.ebuild
new file mode 100644 (file)
index 0000000..28fb3ae
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Virtual for various service managers"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="kernel_linux"
+
+RDEPEND="
+       prefix-guest? ( >=sys-apps/baselayout-prefix-2.2 )
+       !prefix-guest? (
+               || (
+               sys-apps/openrc
+               kernel_linux? ( || (
+                       sys-apps/systemd
+                       sys-process/runit
+                       virtual/daemontools
+       ) ) ) )"