media-video/ffmpeg: rename rtmp useflag to librtmp, bug #509974
authorAlexis Ballier <aballier@gentoo.org>
Sat, 22 Aug 2015 10:05:56 +0000 (12:05 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 22 Aug 2015 10:05:56 +0000 (12:05 +0200)
Package-Manager: portage-2.2.20.1

media-video/ffmpeg/ffmpeg-2.6.3.ebuild
media-video/ffmpeg/ffmpeg-2.6.4.ebuild
media-video/ffmpeg/ffmpeg-2.7.2.ebuild
media-video/ffmpeg/ffmpeg-9999.ebuild
media-video/ffmpeg/metadata.xml

index 2f513ba70b81b118af55790515c6021000cf20e7..cc8493394e12619255d57223629b67f2b2fae6c1 100644 (file)
@@ -75,7 +75,7 @@ FFMPEG_FLAG_MAP=(
                # decoders
                amr:libopencore-amrwb amr:libopencore-amrnb fdk:libfdk-aac
                jpeg2k:libopenjpeg bluray:libbluray celt:libcelt gme:libgme gsm:libgsm
-               modplug:libmodplug opus:libopus quvi:libquvi rtmp:librtmp ssh:libssh
+               modplug:libmodplug opus:libopus quvi:libquvi librtmp ssh:libssh
                schroedinger:libschroedinger speex:libspeex vorbis:libvorbis vpx:libvpx
                zvbi:libzvbi
                # libavfilter options
@@ -207,7 +207,7 @@ RDEPEND="
        opus? ( >=media-libs/opus-1.0.2-r2[${MULTILIB_USEDEP}] )
        pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
        quvi? ( media-libs/libquvi:0.4[${MULTILIB_USEDEP}] )
-       rtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
+       librtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
        samba? ( >=net-fs/samba-3.6.23-r1[${MULTILIB_USEDEP}] )
        schroedinger? ( >=media-libs/schroedinger-1.0.11-r1[${MULTILIB_USEDEP}] )
        sdl? ( >=media-libs/libsdl-1.2.15-r4[sound,video,${MULTILIB_USEDEP}] )
@@ -243,7 +243,7 @@ DEPEND="${RDEPEND}
        ladspa? ( >=media-libs/ladspa-sdk-1.13-r2[${MULTILIB_USEDEP}] )
        libv4l? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
        cpu_flags_x86_mmx? ( >=dev-lang/yasm-1.2 )
-       rtmp? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
+       librtmp? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
        schroedinger? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
        test? ( net-misc/wget sys-devel/bc )
        truetype? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
index f4e269cfb2ffefe53ad95d11bfc1f3e44bcad086..b9a6919e88431e8a61b7f1fe6fa8ef4127f86ae8 100644 (file)
@@ -75,7 +75,7 @@ FFMPEG_FLAG_MAP=(
                # decoders
                amr:libopencore-amrwb amr:libopencore-amrnb fdk:libfdk-aac
                jpeg2k:libopenjpeg bluray:libbluray celt:libcelt gme:libgme gsm:libgsm
-               modplug:libmodplug opus:libopus quvi:libquvi rtmp:librtmp ssh:libssh
+               modplug:libmodplug opus:libopus quvi:libquvi librtmp ssh:libssh
                schroedinger:libschroedinger speex:libspeex vorbis:libvorbis vpx:libvpx
                zvbi:libzvbi
                # libavfilter options
@@ -207,7 +207,7 @@ RDEPEND="
        opus? ( >=media-libs/opus-1.0.2-r2[${MULTILIB_USEDEP}] )
        pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
        quvi? ( media-libs/libquvi:0.4[${MULTILIB_USEDEP}] )
-       rtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
+       librtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
        samba? ( >=net-fs/samba-3.6.23-r1[${MULTILIB_USEDEP}] )
        schroedinger? ( >=media-libs/schroedinger-1.0.11-r1[${MULTILIB_USEDEP}] )
        sdl? ( >=media-libs/libsdl-1.2.15-r4[sound,video,${MULTILIB_USEDEP}] )
@@ -243,7 +243,7 @@ DEPEND="${RDEPEND}
        ladspa? ( >=media-libs/ladspa-sdk-1.13-r2[${MULTILIB_USEDEP}] )
        libv4l? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
        cpu_flags_x86_mmx? ( >=dev-lang/yasm-1.2 )
-       rtmp? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
+       librtmp? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
        schroedinger? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
        test? ( net-misc/wget sys-devel/bc )
        truetype? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
index c568a8f7a547b6017254ec89cb41dfd6f9ad8404..83094e5e4b30f44f0ba19d7fce3b655416b1a3dd 100644 (file)
@@ -75,7 +75,7 @@ FFMPEG_FLAG_MAP=(
                # decoders
                amr:libopencore-amrwb amr:libopencore-amrnb fdk:libfdk-aac
                jpeg2k:libopenjpeg bluray:libbluray celt:libcelt gme:libgme gsm:libgsm
-               modplug:libmodplug opus:libopus quvi:libquvi rtmp:librtmp ssh:libssh
+               modplug:libmodplug opus:libopus quvi:libquvi librtmp ssh:libssh
                schroedinger:libschroedinger speex:libspeex vorbis:libvorbis vpx:libvpx
                zvbi:libzvbi
                # libavfilter options
@@ -207,7 +207,7 @@ RDEPEND="
        opus? ( >=media-libs/opus-1.0.2-r2[${MULTILIB_USEDEP}] )
        pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
        quvi? ( media-libs/libquvi:0.4[${MULTILIB_USEDEP}] )
-       rtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
+       librtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
        samba? ( >=net-fs/samba-3.6.23-r1[${MULTILIB_USEDEP}] )
        schroedinger? ( >=media-libs/schroedinger-1.0.11-r1[${MULTILIB_USEDEP}] )
        sdl? ( >=media-libs/libsdl-1.2.15-r4[sound,video,${MULTILIB_USEDEP}] )
@@ -243,7 +243,7 @@ DEPEND="${RDEPEND}
        ladspa? ( >=media-libs/ladspa-sdk-1.13-r2[${MULTILIB_USEDEP}] )
        libv4l? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
        cpu_flags_x86_mmx? ( >=dev-lang/yasm-1.2 )
-       rtmp? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
+       librtmp? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
        schroedinger? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
        test? ( net-misc/wget sys-devel/bc )
        truetype? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
index fa8dea8b74c5e1384bd5f16014422d94f5931878..47175a4fa230a6976a1f2405ccbfa7ecf865284e 100644 (file)
@@ -75,7 +75,7 @@ FFMPEG_FLAG_MAP=(
                # decoders
                amr:libopencore-amrwb amr:libopencore-amrnb fdk:libfdk-aac
                jpeg2k:libopenjpeg bluray:libbluray celt:libcelt gme:libgme gsm:libgsm
-               modplug:libmodplug opus:libopus quvi:libquvi rtmp:librtmp ssh:libssh
+               modplug:libmodplug opus:libopus quvi:libquvi librtmp ssh:libssh
                schroedinger:libschroedinger speex:libspeex vorbis:libvorbis vpx:libvpx
                zvbi:libzvbi
                # libavfilter options
@@ -209,7 +209,7 @@ RDEPEND="
        opus? ( >=media-libs/opus-1.0.2-r2[${MULTILIB_USEDEP}] )
        pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
        quvi? ( media-libs/libquvi:0.4[${MULTILIB_USEDEP}] )
-       rtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
+       librtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
        samba? ( >=net-fs/samba-3.6.23-r1[${MULTILIB_USEDEP}] )
        schroedinger? ( >=media-libs/schroedinger-1.0.11-r1[${MULTILIB_USEDEP}] )
        sdl? ( >=media-libs/libsdl-1.2.15-r4[sound,video,${MULTILIB_USEDEP}] )
@@ -245,7 +245,7 @@ DEPEND="${RDEPEND}
        ladspa? ( >=media-libs/ladspa-sdk-1.13-r2[${MULTILIB_USEDEP}] )
        libv4l? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
        cpu_flags_x86_mmx? ( >=dev-lang/yasm-1.2 )
-       rtmp? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
+       librtmp? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
        schroedinger? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
        test? ( net-misc/wget sys-devel/bc )
        truetype? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
index f5dbd10fdd8a2ee281b292701d5a155406487cd9..8f0f349c383087bc662c3cc238c0897ef03f2f21 100644 (file)
@@ -38,7 +38,7 @@
        <flag name="pic">Force shared libraries to be built as PIC (this is slower)</flag>
        <flag name="postproc">Build and install libpostproc.</flag>
        <flag name="quvi">Adds support for playing media from Internet services using the quvi project.</flag>
-       <flag name="rtmp">Enable Real Time Messaging Protocol using librtmp</flag>
+       <flag name="librtmp">Enable Real Time Messaging Protocol using librtmp</flag>
        <flag name="schroedinger">Enable Dirac video support (an advanced royalty-free video compression format) via libschroedinger (high-speed implementation in C of the Dirac codec).</flag>
        <flag name="snappy">Enable <pkg>app-arch/snappy</pkg> support. Required for e.g. Vidvox Hap encoder.</flag>
        <flag name="ssh">Enable SSH/sftp support via <pkg>net-libs/libssh</pkg>.</flag>