dev-libs/xml-security-c: 2.0.2 version bump, EAPI=7
authorCraig Andrews <candrews@gentoo.org>
Thu, 6 Dec 2018 20:37:17 +0000 (15:37 -0500)
committerCraig Andrews <candrews@gentoo.org>
Thu, 6 Dec 2018 20:38:00 +0000 (15:38 -0500)
Closes: https://bugs.gentoo.org/show_bug.cgi?id=671140
Closes: https://bugs.gentoo.org/show_bug.cgi?id=671138
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-libs/xml-security-c/Manifest
dev-libs/xml-security-c/xml-security-c-2.0.2.ebuild [new file with mode: 0644]

index 1b18c156e11b68aa6179e4307729ffd9def9c183..0d008450a472445be5f4a130e492a1c0b30d5f7c 100644 (file)
@@ -1 +1,2 @@
 DIST xml-security-c-1.7.3.tar.gz 909320 BLAKE2B 5fa9f3ae53b93104c191b76f8ae4f9dad69c690d409ae3f13864cf011bbbca740c5378c0718abb496811c9814b5a7f237042af22e697bfa2e5044668ff3fbd2d SHA512 ea46709d6706edf345e19132d9998774e50dc7b5947a7b4a55e3627998f5ac66f976fdff0a5015ef3cee73c03c04f3c4cf993efd397082491c2000c6548b89d2
+DIST xml-security-c-2.0.2.tar.gz 904933 BLAKE2B 8e336dd7539778411755a8d45398daa530a2f602a0d57faa29301d1f0b29ab0a61c3f47ead42b740337ea75a28e03f471ae6735d5cd66d31f56d3d5fe3405b1b SHA512 bebadee2daf27181f5bcc955a909397976e8fd2e67f5e546f5adbede0ca790647cbec9181b0b609da59d525ff3baa9f899af2a3d815bc7a2f3a57bd8b30c011b
diff --git a/dev-libs/xml-security-c/xml-security-c-2.0.2.ebuild b/dev-libs/xml-security-c/xml-security-c-2.0.2.ebuild
new file mode 100644 (file)
index 0000000..ea768c1
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Apache C++ XML security libraries"
+HOMEPAGE="http://santuario.apache.org/"
+SRC_URI="mirror://apache/santuario/c-library/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug examples libressl nss static-libs xalan"
+
+RDEPEND=">=dev-libs/xerces-c-3.2
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+       nss? ( dev-libs/nss )
+       xalan? ( dev-libs/xalan-c )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CHANGELOG.txt NOTICE.txt )
+
+src_configure() {
+       econf \
+               --with-openssl \
+               $(use_enable static-libs static) \
+               $(use_enable debug) \
+               $(use_with xalan) \
+               $(use_with nss)
+}
+
+src_install() {
+       default
+       if use examples ; then
+               docinto examples
+               dodoc xsec/samples/*.cpp
+       fi
+}