sys-apps/lcdutils: bump to EAPI=7
authorConrad Kostecki <conrad@kostecki.com>
Wed, 6 Nov 2019 19:46:07 +0000 (20:46 +0100)
committerAaron Bauman <bman@gentoo.org>
Fri, 8 Nov 2019 02:39:31 +0000 (21:39 -0500)
Also taking ownership by myself.

Closes: https://bugs.gentoo.org/697208
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Signed-off-by: Aaron Bauman <bman@gentoo.org>
sys-apps/lcdutils/files/lcdutils-0.2-makefile.patch [new file with mode: 0644]
sys-apps/lcdutils/lcdutils-0.2-r1.ebuild [new file with mode: 0644]
sys-apps/lcdutils/metadata.xml

diff --git a/sys-apps/lcdutils/files/lcdutils-0.2-makefile.patch b/sys-apps/lcdutils/files/lcdutils-0.2-makefile.patch
new file mode 100644 (file)
index 0000000..a67db0c
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/Makefile 2002-07-08 15:31:37.000000000 +0200
++++ b/Makefile 2019-11-06 20:38:11.499806312 +0100
+@@ -1,13 +1,14 @@
+ #CC=mips-uclibc-gcc
+ #LDFLAGS=-static
+-CFLAGS=-O2 -Wall
++CFLAGS?=-O2 -Wall
+ all: putlcd buttond
+ install: all
+-      install putlcd /usr/local/sbin
+-      install buttond /usr/local/sbin
++      install -d ${DESTDIR}/usr/bin
++      install putlcd ${DESTDIR}/usr/bin
++      install buttond ${DESTDIR}/usr/bin
+ clean:
+       rm -f putlcd buttond *.o
diff --git a/sys-apps/lcdutils/lcdutils-0.2-r1.ebuild b/sys-apps/lcdutils/lcdutils-0.2-r1.ebuild
new file mode 100644 (file)
index 0000000..cf75998
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="(Sun) Cobalt Qube/RaQ button reading and LCD writing utilities"
+HOMEPAGE="https://people.debian.org/~pm/mips-cobalt/"
+SRC_URI="https://people.debian.org/~pm/mips-cobalt/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~mips ~x86"
+
+PATCHES=(
+       "${FILESDIR}/include-stdlib.h-for-exit.patch"
+       "${FILESDIR}/${P}-makefile.patch"
+)
+
+src_prepare() {
+       default
+
+       tc-export CC
+}
index 14e7453a3b0464b14b91072f0576cdacd00db15f..542e1c8573016090c39fdc3ea9fff35293138491 100644 (file)
@@ -1,12 +1,20 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
+       <maintainer type="person">
+               <email>ck+gentoo@bl4ckb0x.de</email>
+               <name>Conrad Kostecki</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
        <maintainer type="project">
                <email>mips@gentoo.org</email>
                <name>Mips Team</name>
        </maintainer>
-
        <longdescription>
-               Provides utilities for Cobalt Microserver systems to write to the LCD and read button input
+               Provides utilities for the (Sun) Cobalt Microserver Systems
+               to write to the LCD and read the button input.
        </longdescription>
 </pkgmetadata>