kde-frameworks/extra-cmake-modules: Don't run tests in parallel
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 11 Feb 2020 14:54:53 +0000 (15:54 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 11 Feb 2020 14:55:02 +0000 (15:55 +0100)
Reported-by: Paolo Pedroni <paolo.pedroni@iol.it>
Closes: https://bugs.gentoo.org/701854
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.67.0.ebuild

index 35862e15da7ce847fbf3543217c821040211bfa2..5a9859acaa9a7f6ad6dac6e3859fe3e0d6ecae93 100644 (file)
@@ -66,7 +66,9 @@ src_configure() {
 src_test() {
        # ECMToolchainAndroidTest passes but then breaks src_install
        # ECMPoQmToolsTest is broken, bug #627806
+       # possible race condition with multiple jobs, bug #701854
        local myctestargs=(
+               -j1
                -E "(ECMToolchainAndroidTest|ECMPoQmToolsTest)"
        )