sys-libs/ldb: fix new REQUIRED_USE for tests to actually apply
authorBen Kohler <bkohler@gentoo.org>
Sat, 28 Mar 2020 18:00:00 +0000 (13:00 -0500)
committerBen Kohler <bkohler@gentoo.org>
Sat, 28 Mar 2020 18:00:44 +0000 (13:00 -0500)
Closes: https://bugs.gentoo.org/709600
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
sys-libs/ldb/ldb-2.0.8.ebuild
sys-libs/ldb/ldb-2.0.9.ebuild
sys-libs/ldb/ldb-2.1.1.ebuild

index 088655213faf85096f6c20ce1f745f72f12fd0b0..c4654f0379d34ba3d701d7725a233816af0b2faf 100644 (file)
@@ -17,7 +17,6 @@ KEYWORDS="~alpha amd64 arm arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 sparc x86"
 IUSE="doc +ldap +lmdb python test"
 
 RESTRICT="!test? ( test )"
-REQUIRED_USE="test? ( python )"
 
 RDEPEND="
        !elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
@@ -38,7 +37,8 @@ DEPEND="dev-libs/libxslt
        ${RDEPEND}
 "
 
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+       test? ( python )"
 
 WAF_BINARY="${S}/buildtools/bin/waf"
 
index 0054406aec4812fb6de4aa2cb2761d472c238f4a..484c8a1afd84fa8f4159d9e566867fe0b49c9156 100644 (file)
@@ -17,7 +17,6 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~
 IUSE="doc +ldap +lmdb python test"
 
 RESTRICT="!test? ( test )"
-REQUIRED_USE="test? ( python )"
 
 RDEPEND="
        !elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
@@ -38,7 +37,8 @@ DEPEND="dev-libs/libxslt
        ${RDEPEND}
 "
 
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+       test? ( python )"
 
 WAF_BINARY="${S}/buildtools/bin/waf"
 
index c8b8d6555867af80c859291ed1ddb9a87d171ede..e1deb520305b41d59849557d505f9f711cc6a9a0 100644 (file)
@@ -17,7 +17,6 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~
 IUSE="doc +ldap +lmdb python test"
 
 RESTRICT="!test? ( test )"
-REQUIRED_USE="test? ( python )"
 
 RDEPEND="
        !elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
@@ -38,7 +37,8 @@ DEPEND="dev-libs/libxslt
        ${RDEPEND}
 "
 
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+       test? ( python )"
 
 WAF_BINARY="${S}/buildtools/bin/waf"