dev-libs/nanomsg: EAPI-7 bump, use cmake.eclass
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 19 Mar 2020 21:16:40 +0000 (22:16 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 19 Mar 2020 21:17:56 +0000 (22:17 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/nanomsg/nanomsg-1.1.5.ebuild

index 73f7851f7dd1e52e8c60252ed1d7fbbe19099493..6dc699b6e733d3847d656d8d174949dccc2d3ac8 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
+CMAKE_ECLASS=cmake
 inherit cmake-multilib
 
 DESCRIPTION="High-performance messaging interface for distributed applications"
@@ -32,5 +33,5 @@ multilib_src_configure() {
                        -DNN_ENABLE-NANOCAT=OFF
                )
        fi
-       cmake-utils_src_configure
+       cmake_src_configure
 }