net-misc/kea: Synced live ebuild
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 27 Feb 2020 08:20:55 +0000 (09:20 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 27 Feb 2020 08:59:34 +0000 (09:59 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-misc/kea/kea-9999.ebuild

index c915fee4402e36634a156ebff3c9bdcc5f5bf9d1..2f6a4dc21e8ae4b45c62c0eff0782677d005517c 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit toolchain-funcs user
+inherit toolchain-funcs
 
 MY_PV="${PV//_p/-P}"
 MY_PV="${MY_PV/_/-}"
@@ -34,7 +34,9 @@ DEPEND="
        openssl? ( dev-libs/openssl:0= )
        postgres? ( dev-db/postgresql:* )
 "
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+       acct-group/dhcp
+       acct-user/dhcp"
 BDEPEND="virtual/pkgconfig"
 
 S="${WORKDIR}/${MY_P}"
@@ -69,8 +71,3 @@ src_install() {
        keepdir /var/{lib,run}/${PN} /var/log
        find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
 }
-
-pkg_preinst() {
-       enewgroup dhcp
-       enewuser dhcp -1 -1 /var/lib/dhcp dhcp
-}