media-libs/gst-plugins-ugly: Version bump, 1.16.2
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>
Sat, 15 Feb 2020 22:10:05 +0000 (23:10 +0100)
committerMart Raudsepp <leio@gentoo.org>
Sun, 3 May 2020 19:12:11 +0000 (22:12 +0300)
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
media-libs/gst-plugins-ugly/Manifest
media-libs/gst-plugins-ugly/gst-plugins-ugly-1.16.2.ebuild [new file with mode: 0644]

index cda56f7ff097ec3e24f7aa6968ebba6420a8b438..ee418bb501fd5c285be9e32a04fd60b5f2efd6fe 100644 (file)
@@ -1 +1,2 @@
 DIST gst-plugins-ugly-1.14.3.tar.xz 889492 BLAKE2B 0c76ca28e1f062d0eac438f1692d2af33536719913ec10229eb6bc64f1f957bc7f6afe45e1c528ab4015c25dec61b8b9d2c517fee78a8a992c76bd41ff9e75d1 SHA512 0866bbcc3f1d0d668e77b5ef83fa7469dc80c957d2c6526126e761db46e83ff18d941c247833d27336106d8ba043e9ad50cafbddbff241f95bb16f9b1a0fbacc
+DIST gst-plugins-ugly-1.16.2.tar.xz 893964 BLAKE2B c607a7aa3459625a930021d247705f00e418e57557c57b8f9793bce74cb5c4d708b253250f0bbebd9698e9ff80d5636d578dded8c360ca2d34e3d43c9a722416 SHA512 9f393043f51b12b376607e68b3b86437af86e321e3a3566e59c7f3507ed26622211df87e30a23bcc927f37bc11f53ca3b29f1b12bf58e623ce18edc88a9cdee3
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.16.2.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.16.2.ebuild
new file mode 100644 (file)
index 0000000..20f7b7b
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE="gst-plugins-ugly"
+
+inherit gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2+" # some split plugins are LGPL but combining with a GPL library
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+       >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+       >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+       >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       >=dev-util/gtk-doc-am-1.12
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.14.3-make43.patch # remove when bumping and switching to Meson
+)
+
+multilib_src_configure() {
+       gstreamer_multilib_src_configure
+
+       if multilib_is_native_abi; then
+               ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+       fi
+
+}
+
+multilib_src_install_all() {
+       DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+       einstalldocs
+       find "${ED}" -name '*.la' -delete || die
+}