x11-apps/radeontop: Bump to 1.0, sync live
authorHarri Nieminen <moikkis@gmail.com>
Sat, 11 Mar 2017 09:38:56 +0000 (11:38 +0200)
committerDavid Seifert <soap@gentoo.org>
Thu, 16 Mar 2017 19:12:50 +0000 (20:12 +0100)
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Closes: https://github.com/gentoo/gentoo/pull/4186

x11-apps/radeontop/Manifest
x11-apps/radeontop/radeontop-1.0.ebuild [moved from x11-apps/radeontop/radeontop-0.9.ebuild with 66% similarity]
x11-apps/radeontop/radeontop-9999.ebuild

index eb0840952d10644986f042505fa3f7e84fe99689..81916c7e4c180ea06dffb3f14eae5d3784858a1a 100644 (file)
@@ -1 +1 @@
-DIST radeontop-0.9.tar.gz 31186 SHA256 e78a56d1222c8a45f08f09409f178ddda83461085b012e5ba54b716e6c8dd61d SHA512 d219e000c3ed39e3022c8316a3412f423b363abafefb3d8d6e80fa2ac505084afaf4a18b3f6bba5918f29c1a659668e07c08d02a6fdbf9ef1764758350db449a WHIRLPOOL 744834650ae98fd87e34ca1511183a1c3a9e1b215b3a31e7872b8329f7bfd8d97df33a9425e47d2c6169412f8000b516f09526978fee4042016a76e8574f1cd6
+DIST radeontop-1.0.tar.gz 32677 SHA256 a997ea92f38a53d59db4d8e846aec4cc04cee8b79939e89d5eb9e31c57b468fc SHA512 bd7e8ecff962d8ac3072f3f1fa7a5d9981e2da28b38a1f234f6fe550511c3fbda2c1c6e9a6d1120bf99ef3ae621a91ff67c451eaf98dfa1264e9e6a59ae55e08 WHIRLPOOL 0813d44cf0801e7ace48704cf6f68d7a0d26cbb2dd6a4d47b2854c4ccbdce409dec45f4acc40678f7d1aca452989a90e7a886bc05cf8e62be5285ad97ae7b9ad
similarity index 66%
rename from x11-apps/radeontop/radeontop-0.9.ebuild
rename to x11-apps/radeontop/radeontop-1.0.ebuild
index 1a3e1530557855d029b307385a6ea37f8586c64c..7b81237a64ba1e3448a49d9f4446013f9eaf5f27 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=6
+inherit toolchain-funcs
 
 DESCRIPTION="Utility to view Radeon GPU utilization"
 HOMEPAGE="https://github.com/clbr/radeontop"
@@ -14,10 +14,14 @@ KEYWORDS="~amd64 ~x86"
 IUSE="nls"
 
 RDEPEND="
-       sys-libs/ncurses
-       x11-libs/libpciaccess
+       sys-libs/ncurses:0=
        x11-libs/libdrm
-       nls? ( sys-libs/ncurses[unicode] virtual/libintl )
+       x11-libs/libpciaccess
+       x11-libs/libxcb
+       nls? (
+               sys-libs/ncurses:0=[unicode]
+               virtual/libintl
+       )
 "
 DEPEND="${RDEPEND}
        virtual/pkgconfig
@@ -25,16 +29,16 @@ DEPEND="${RDEPEND}
 "
 
 src_prepare() {
-       epatch_user
+       default
 
-cat > include/version.h << EOF || die
-#ifndef VER_H
-#define VER_H
+       cat > include/version.h <<-EOF || die
+       #ifndef VER_H
+       #define VER_H
 
-#define VERSION "${PV}"
+       #define VERSION "${PV}"
 
-#endif
-EOF
+       #endif
+       EOF
        >getver.sh || die
        touch .git || die
 }
@@ -42,6 +46,7 @@ EOF
 src_configure() {
        tc-export CC
        export nls=$(usex nls 1 0)
+       export xcb=1
        # Do not add -g or -s to CFLAGS
        export plain=1
 }
index 79d4bdc36db569f2efc55eb324af586cdce21fbd..e3919c9db7f29f057748bd7f2db7e123f450fec6 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-inherit eutils toolchain-funcs git-r3
+EAPI=6
+inherit toolchain-funcs git-r3
 
 DESCRIPTION="Utility to view Radeon GPU utilization"
 HOMEPAGE="https://github.com/clbr/radeontop"
@@ -14,23 +14,24 @@ KEYWORDS=""
 IUSE="nls"
 
 RDEPEND="
-       sys-libs/ncurses
-       x11-libs/libpciaccess
+       sys-libs/ncurses:0=
        x11-libs/libdrm
-       nls? ( sys-libs/ncurses[unicode] virtual/libintl )
+       x11-libs/libpciaccess
+       x11-libs/libxcb
+       nls? (
+               sys-libs/ncurses:0=[unicode]
+               virtual/libintl
+       )
 "
 DEPEND="${RDEPEND}
        virtual/pkgconfig
        nls? ( sys-devel/gettext )
 "
 
-src_prepare() {
-       epatch_user
-}
-
 src_configure() {
        tc-export CC
        export nls=$(usex nls 1 0)
+       export xcb=1
        # Do not add -g or -s to CFLAGS
        export plain=1
 }