games-util/lutris: Version bump to 0.4.23
authornatemonster321 <dhanas.nathan@gmail.com>
Sat, 1 Dec 2018 00:49:34 +0000 (19:49 -0500)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 2 Mar 2019 00:03:00 +0000 (01:03 +0100)
Package-Manager: Portage-2.3.52, Repoman-2.3.12

Signed-off-by: Nathan Dhanas <dhanas.nathan@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/10533
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
games-util/lutris/Manifest
games-util/lutris/lutris-0.4.23.ebuild [new file with mode: 0644]

index f4836fa54ddb3009b1d51ce72e98a738c1c66970..c379f7c78a785806ba01c9df9b5731b4d9c00c64 100644 (file)
@@ -1 +1,2 @@
 DIST lutris-0.4.14.tar.gz 1617493 BLAKE2B c97d0e31657252c4ae5c6718151f028d273831cdb9f21b748ada651686cf3aa51a618a007db87528d84f21dca292509399f9bb1f0c0444c57e369b13b9ae79a0 SHA512 d229d7f79b3395db22ad49abc02ca5e08db9465258be33fcefe743c0a099e1ca507b6b9c28f03d2a6857489f7f2e19fca38803f6876df88a96b060ed5f7f94bc
+DIST lutris-0.4.23.tar.gz 1831736 BLAKE2B 9da20d5545e9d2474bed436443fed325beb3ed2e3e945cb27e25fbce88ac7aeb9547a0a1bcd74349e5c7bda0dd6be50949b5abaa1fc091a21217b330c6fe655f SHA512 a0860920e01568888db5ac9a52c0d33a5108af33906ea411d4621dec4b059c399b17ca35c245bf9bfb506c6b242d32d917d3ade6898f619e00f9361117632fb3
diff --git a/games-util/lutris/lutris-0.4.23.ebuild b/games-util/lutris/lutris-0.4.23.ebuild
new file mode 100644 (file)
index 0000000..e99755e
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+DESCRIPTION="An open source gaming platform for GNU/Linux"
+HOMEPAGE="https://lutris.net/"
+
+if [[ "${PV}" == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/lutris/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/lutris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+       dev-python/dbus-python[${PYTHON_USEDEP}]
+       dev-python/pygobject:3[${PYTHON_USEDEP}]
+       dev-python/python-evdev[${PYTHON_USEDEP}]
+       dev-python/pyyaml[${PYTHON_USEDEP}]
+       net-libs/libsoup
+       x11-apps/xrandr
+       x11-apps/xgamma"
+
+src_install() {
+       distutils-r1_src_install
+       newdoc debian/changelog CHANGELOG
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+       xdg_desktop_database_update
+
+       elog "For a list of optional dependencies (runners) see:"
+       elog "/usr/share/doc/${PF}/README.rst.bz2"
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+       xdg_desktop_database_update
+}