dev-util/cram: Add pypy3 and py3.7 support
authorDavid Seifert <soap@gentoo.org>
Thu, 30 May 2019 20:57:19 +0000 (22:57 +0200)
committerDavid Seifert <soap@gentoo.org>
Thu, 30 May 2019 20:57:19 +0000 (22:57 +0200)
* EAPI=7
* Add test suite
* Remove py2, as it causes failures in the test suite
  when dev-python/configparser is installed

Package-Manager: Portage-2.3.67, Repoman-2.3.13
Signed-off-by: David Seifert <soap@gentoo.org>
dev-util/cram/cram-0.7.ebuild

index 05dedeb0a0af844d853d4816409a406a19fed94a..80888de3e6c404e261a36cbac97e430a32f2b0d5 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
 
 inherit distutils-r1
 
@@ -14,7 +14,8 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 x86 ~amd64-fbsd ~x86-fbsd"
-IUSE=""
 
-DEPEND=""
-RDEPEND="${DEPEND}"
+python_test() {
+       distutils_install_for_testing
+       "${EPYTHON}" "${TEST_DIR}"/scripts/cram tests || die "Tests fail with ${EPYTHON}"
+}