dev-python/pytest-runner: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Fri, 5 Jan 2018 23:33:04 +0000 (00:33 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 00:44:25 +0000 (01:44 +0100)
dev-python/pytest-runner/Manifest
dev-python/pytest-runner/pytest-runner-2.10.1.ebuild [deleted file]

index 412c60c785d881ba25f8668748a24c82c50a70d5..38586bb2c0ba1e5180bcb2686cdf84ebd629eb66 100644 (file)
@@ -1,3 +1,2 @@
-DIST pytest-runner-2.10.1.tar.gz 8815 BLAKE2B afc614bb9a446eed2e443dede3d1df97e093782c04e4c0052334c309e291c7baca8d6dade11c7a47f90efdaa4b0ac220507c5c096cb0cfeb6e95a1d62503bd4e SHA512 11c570051a0a7ff56fbb4fdc2a87185af6bbcccc05be012eeaefd775efbf21a3fb167a95ae603d627461b3775ee8cfb56b10d356044a4ae3966a7bf9f1b1f4a8
 DIST pytest-runner-2.11.1.tar.gz 9661 BLAKE2B 300b63de61ef36c299a95c60af469b071c27ae483f641c7cad594f7b6f582d9e1e076192f9fd5019850cf9227af183e9f80b4049719d074a180e72c25521bc14 SHA512 5249e0a368bab21bb034a9b0121edbcda635f559cc22ba79c87565dcbc070056bfed47a69c16f4733403f61ea5b73adfd1ccf945700116043cbf3940d37d4067
 DIST pytest-runner-2.6.2.tar.gz 6379 BLAKE2B 4f676a4cd59309cdd0e6462c83718482622817781d302ed95a2b7cb9d92a0b0f38b411c1172ecce9003f5781cdb168338bce6f446b1c91069a2024fb75574bfc SHA512 6a993e8729d5e203986f2526d46e96b7ac19e65fc26493a55a98e858304ecde0c47576476864a0ee1817ea1a7b02cfda952fc03f79b84fff249021f140f3d00d
diff --git a/dev-python/pytest-runner/pytest-runner-2.10.1.ebuild b/dev-python/pytest-runner/pytest-runner-2.10.1.ebuild
deleted file mode 100644 (file)
index 2e89dab..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Adds support for tests during installation of setup.py files"
-HOMEPAGE="https://pypi.python.org/pypi/pytest-runner https://github.com/pytest-dev/pytest-runner"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-SLOT="0"
-IUSE="doc"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       doc? ( dev-python/docutils[${PYTHON_USEDEP}] )
-       "
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-
-# Test not included
-RESTRICT="test"
-
-python_compile_all() {
-       # The build by rst2html.py makes non fatal errors building index.rst
-       if use doc; then
-               rst2html.py docs/history.rst > docs/history.html
-               rst2html.py docs/index.rst > docs/index.html
-               HTML_DOCS=( docs/*.html )
-       fi
-}
-
-python_test() {
-       esetup.py pytest
-}