app-doc/autobook: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 18 Oct 2019 12:18:24 +0000 (14:18 +0200)
committerDavid Seifert <soap@gentoo.org>
Fri, 18 Oct 2019 12:18:24 +0000 (14:18 +0200)
Closes: https://bugs.gentoo.org/697386
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
app-doc/autobook/autobook-1.5.ebuild

index 30c31ea61eaabd555324b700bc08c5fbc8988610..5d6cf849475020bb9a6074b7ef55e42abbccf238 100644 (file)
@@ -1,33 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 DESCRIPTION="GNU Autoconf, Automake and Libtool"
 HOMEPAGE="https://sourceware.org/autobook/"
-SRC_URI="https://sourceware.org/autobook/${P}.tar.gz
-       examples? (
-               https://sourceware.org/autobook/foonly-2.0.tar.gz
-               https://sourceware.org/autobook/small-2.0.tar.gz
-               https://sourceware.org/autobook/hello-2.0.tar.gz
-               https://sourceware.org/autobook/convenience-2.0.tar.gz
-       )"
+SRC_URI="
+       https://sourceware.org/autobook/${P}.tar.gz
+       https://sourceware.org/autobook/foonly-2.0.tar.gz
+       https://sourceware.org/autobook/small-2.0.tar.gz
+       https://sourceware.org/autobook/hello-2.0.tar.gz
+       https://sourceware.org/autobook/convenience-2.0.tar.gz"
 
 LICENSE="OPL"
 SLOT="0"
 KEYWORDS="amd64 arm hppa ia64 m68k ppc s390 sh x86"
-IUSE="examples"
-
-DEPEND=""
-RDEPEND=""
 
 src_install() {
-       dohtml * || die
-       if use examples ; then
-               local d
-               for d in {convenience,foonly,hello,small}-2.0 ; do
-                       insinto /usr/share/doc/${PF}/${d}
-                       doins -r "${WORKDIR}"/${d}/* || die "doins ${d} failed"
-               done
-       fi
+       local HTML_DOCS=( . )
+       einstalldocs
+
+       local d
+       for d in {convenience,foonly,hello,small}-2.0; do
+               dodoc -r "${WORKDIR}"/${d}
+       done
 }