net-wireless/iwd: skip eautoreconf for release builds
authorMike Gilbert <floppym@gentoo.org>
Fri, 1 Nov 2019 15:01:57 +0000 (11:01 -0400)
committerBen Kohler <bkohler@gentoo.org>
Fri, 1 Nov 2019 16:22:55 +0000 (11:22 -0500)
Bug: https://bugs.gentoo.org/699042
Package-Manager: Portage-2.3.78_p4, Repoman-2.3.17_p100
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
net-wireless/iwd/iwd-9999.ebuild

index 72992be15e1185112bd5b68291b00854409aecaa..7f6f1bdeef404e60c60c19238420527528caaaab 100644 (file)
@@ -2,11 +2,11 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit autotools flag-o-matic linux-info systemd
+inherit flag-o-matic linux-info systemd
 
 if [[ ${PV} == *9999* ]]; then
        EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/wireless/iwd.git"
-       inherit git-r3
+       inherit autotools git-r3
 else
        SRC_URI="https://www.kernel.org/pub/linux/network/wireless/${P}.tar.xz"
        KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~sparc ~x86"
@@ -110,7 +110,9 @@ src_unpack() {
 
 src_prepare() {
        default
-       eautoreconf
+       if [[ ${PV} == *9999* ]] ; then
+               eautoreconf
+       fi
 }
 
 src_configure() {