dev-ros/rosconsole_bridge: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 15:03:27 +0000 (17:03 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 15:03:27 +0000 (17:03 +0200)
Package-Manager: portage-2.2.21

dev-ros/rosconsole_bridge/Manifest [new file with mode: 0644]
dev-ros/rosconsole_bridge/metadata.xml [new file with mode: 0644]
dev-ros/rosconsole_bridge/rosconsole_bridge-0.4.2.ebuild [new file with mode: 0644]
dev-ros/rosconsole_bridge/rosconsole_bridge-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/rosconsole_bridge/Manifest b/dev-ros/rosconsole_bridge/Manifest
new file mode 100644 (file)
index 0000000..431ffce
--- /dev/null
@@ -0,0 +1 @@
+DIST rosconsole_bridge-0.4.2.tar.gz 3974 SHA256 0834456f97e97f30ed27a6a234dac4e829970bffc20b439f4fcf442f0ba04d0c SHA512 ee44f0967d6325bdd20a6c0716502f93a39b5ac22ce9abbde906328ebb1e6fa61f1f4170f6a7fe2ea83cde255b9cb5159153ab23c911524743f0e63e6656330a WHIRLPOOL 3daee3baf0c80993596238304efb30ab59946e42de178db3b3c743eaa4f964a8b440b63120e87976d9af6372fcdf658f12a6e4a88b52af28583778915246cab1
diff --git a/dev-ros/rosconsole_bridge/metadata.xml b/dev-ros/rosconsole_bridge/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rosconsole_bridge/rosconsole_bridge-0.4.2.ebuild b/dev-ros/rosconsole_bridge/rosconsole_bridge-0.4.2.ebuild
new file mode 100644 (file)
index 0000000..2dd99c1
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/rosconsole_bridge"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Connects console_bridge-based logging to rosconsole-based logging"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/console_bridge
+       dev-ros/rosconsole"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       # fix libdir
+       sed -i \
+               -e 's:DESTINATION lib:DESTINATION ${CMAKE_INSTALL_LIBDIR}:' \
+               CMakeLists.txt || die
+       ros-catkin_src_prepare
+}
diff --git a/dev-ros/rosconsole_bridge/rosconsole_bridge-9999.ebuild b/dev-ros/rosconsole_bridge/rosconsole_bridge-9999.ebuild
new file mode 100644 (file)
index 0000000..2dd99c1
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/rosconsole_bridge"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Connects console_bridge-based logging to rosconsole-based logging"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/console_bridge
+       dev-ros/rosconsole"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       # fix libdir
+       sed -i \
+               -e 's:DESTINATION lib:DESTINATION ${CMAKE_INSTALL_LIBDIR}:' \
+               CMakeLists.txt || die
+       ros-catkin_src_prepare
+}