x11-themes/adwaita-qt: Bump to 1.1.1
authorPacho Ramos <pacho@gentoo.org>
Sun, 15 Dec 2019 14:48:16 +0000 (15:48 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 15 Dec 2019 15:22:28 +0000 (16:22 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.19
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
x11-themes/adwaita-qt/Manifest
x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild [new file with mode: 0644]

index 74c4878b7a551cb373177f9b64b9a5b047ec5f0c..47c572071c0295c9a9966a060a3caed8a6b31522 100644 (file)
@@ -1 +1,2 @@
 DIST adwaita-qt-1.1.0.tar.gz 435576 BLAKE2B e85e918e2527cc26f7804f1b03e75163b8c30d46402e3de3dca7afb93ac7abd81fe5e10b4d858859cf9abf443ec57cf74cc1ab578a45798dcb73d4b17da08cc5 SHA512 5203b64cb9e4038579c68ae8f52bc8c2fcdaf0ab46ce134f2a92b318493cc69718ce4d69968f1da20fcdf5f5492c38a6a225475f74f75390ada1337d35504a01
+DIST adwaita-qt-1.1.1.tar.gz 435566 BLAKE2B c8ca8df84ce06311b0937d994a859bb6e71a4a45570c179bdf3ded144bee06c93d8d80b300db3786b1bcc8db7f2b1d78423c8d8b0456079c4563924b2a036abc SHA512 6d11fc8eecc94da4f2e3798ee5147258f277032b23a82d5bf8d3414943ac89c5ebd056d519338959c72a8a45d1638ab8cfeac01b3f3fd1118b4c89eb0c8b5608
diff --git a/x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild b/x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild
new file mode 100644 (file)
index 0000000..bfb8d37
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-utils
+
+DESCRIPTION="A style to bend Qt applications to look like they belong into GNOME Shell"
+HOMEPAGE="https://github.com/FedoraQt/adwaita-qt"
+SRC_URI="https://github.com/FedoraQt/${PN}/archive/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+
+IUSE="gnome"
+
+RDEPEND="
+       gnome? ( x11-themes/QGnomePlatform )
+       dev-qt/qtwidgets:5
+       dev-qt/qtdbus:5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+       BUILD_DIR="${WORKDIR}/${PN}_qt5"
+       local mycmakeargs=( -DUSE_QT4=OFF )
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       local _d
+       for _d in "${WORKDIR}"/${PN}_qt*; do
+               cmake-utils_src_compile -C "${_d}"
+       done
+}
+
+src_install() {
+       local _d
+       for _d in "${WORKDIR}"/${PN}_qt*; do
+               cmake-utils_src_install -C "${_d}"
+       done
+}