dev-lang/lazarus: version bump 2.0.6
authorHorea Christian <chr@chymera.eu>
Tue, 31 Mar 2020 02:53:14 +0000 (22:53 -0400)
committerAmy Liffey <amynka@gentoo.org>
Sat, 25 Apr 2020 13:16:19 +0000 (15:16 +0200)
and removed broken python USE flag
https://github.com/gentoo/gentoo/pull/13744

Closes: https://bugs.gentoo.org/719142
Closes: https://github.com/gentoo/gentoo/pull/15183
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Horea Christian <chr@chymera.eu>
Signed-off-by: Amy Liffey <amynka@gentoo.org>
dev-lang/lazarus/Manifest
dev-lang/lazarus/lazarus-2.0.6.ebuild [new file with mode: 0644]

index bc8f8481aefe2600dd8dba5067f53950c8b7c911..bb6f45d32403b8384730dc21ab61c5feac4867a2 100644 (file)
@@ -3,3 +3,4 @@ DIST lazarus-1.8.4-python.tar.gz 1060859 BLAKE2B 4d6f7dc275aacd0f70d9f7c85aba99a
 DIST lazarus-1.8.4.tar.gz 63130653 BLAKE2B f9b2ba9971f1a9a9c3b8d2004bd3516c12db5384bb6243ef275c2fc0d458634fba0c1c23e7ecd5c160c1204d6cc2b4ebc340ce8bb5cfdd9c531f8c36ae59d1e2 SHA512 82cdc3c32dddf8e67c0bed9292a9a924227bab50f22ca479f5e98ecccbf60dd66c7f886ecb8e2979d9d8fccc3d25462ee8c55fcab085aa4194b4704660e0b95d
 DIST lazarus-2.0.2-python.tar.gz 1060859 BLAKE2B 4d6f7dc275aacd0f70d9f7c85aba99a7722b02165a5bf287bfeed46f28e3b36c5abeac19bd7c6555250102dce169f7c9c213b634ce1b634c24dadc84171aed10 SHA512 f244b4e86410fdb2ffe8ccba7fcb51c270286172b6102f757118827cac3b652210a625d65dd6c017c1992983527792ed64334291ab0e0b824f187316452c56b5
 DIST lazarus-2.0.2.tar.gz 67092332 BLAKE2B 12fdca5b0d7c8bcad4f1c6a70c2ebb1d0974b0884cf89135be069744f01527fcd5b2a4b4c898cb500519ec3518025da453087954722cab43a60c1cdb164371d4 SHA512 0d2bf26afa3128104181fbe57b1adeaba3bb589b0a3b72598507825a3f08201d4480c6cff510a6f866dca4d49417fac3a2f68ca7e58fabe4f4e3bad97323c071
+DIST lazarus-2.0.6.tar.gz 65558951 BLAKE2B f5289562adcfeab86af074de9fc44d7faf5939655587ea9951559bbefc15ce1730e7b7dafb6ec1d0a11eb0f8f069309b8fa0a305051c5cc9ea0fcf9665e883bc SHA512 cdb4c5861e130c12bf0a4938a73c439f2766a73008678028d7e9c9bcabe7b277e70025a7c720a5c14c157cf0227e0ff629a44cf983537b3afbf341343e816d07
diff --git a/dev-lang/lazarus/lazarus-2.0.6.ebuild b/dev-lang/lazarus/lazarus-2.0.6.ebuild
new file mode 100644 (file)
index 0000000..c471d8b
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop
+
+FPCVER="3.0.4"
+
+DESCRIPTION="Lazarus IDE is a feature rich visual programming environment emulating Delphi"
+HOMEPAGE="https://www.lazarus-ide.org/"
+SRC_URI="https://sourceforge.net/projects/${PN}/files/Lazarus%20Zip%20_%20GZip/Lazarus%20${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1-with-linking-exception"
+SLOT="0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+DEPEND=">=dev-lang/fpc-${FPCVER}[source]
+       net-misc/rsync
+       x11-libs/gtk+:2
+       >=sys-devel/binutils-2.19.1-r1:="
+RDEPEND="${DEPEND}"
+
+RESTRICT="strip" #269221
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.26-fpcsrc.patch )
+
+src_prepare() {
+       default
+       # Use default configuration (minus stripping) unless specifically requested otherwise
+       if ! test ${PPC_CONFIG_PATH+set} ; then
+               local FPCVER=$(fpc -iV)
+               export PPC_CONFIG_PATH="${WORKDIR}"
+               sed -e 's/^FPBIN=/#&/' /usr/lib/fpc/${FPCVER}/samplecfg |
+                       sh -s /usr/lib/fpc/${FPCVER} "${PPC_CONFIG_PATH}" || die
+       fi
+       sed -i \
+               -e "s;SecondaryConfigPath:='/etc/lazarus';SecondaryConfigPath:=ExpandFileNameUTF8('~/.lazarus');g" \
+               -e "s;PrimaryConfigPath:=ExpandFileNameUTF8('~/.lazarus');PrimaryConfigPath:='/etc/lazarus';g" \
+               ide/include/unix/lazbaseconf.inc \
+               || die
+}
+
+src_compile() {
+       LCL_PLATFORM=gtk2 emake \
+               $(usex minimal "" "bigide") \
+               -j1
+}
+
+src_install() {
+       diropts -m0755
+       dodir /usr/share
+       # Using rsync to avoid unnecessary copies and cleaning...
+       # Note: *.o and *.ppu are needed
+       rsync -a \
+               --exclude="CVS"     --exclude=".cvsignore" \
+               --exclude="*.ppw"   --exclude="*.ppl" \
+               --exclude="*.ow"    --exclude="*.a"\
+               --exclude="*.rst"   --exclude=".#*" \
+               --exclude="*.~*"    --exclude="*.bak" \
+               --exclude="*.orig"  --exclude="*.rej" \
+               --exclude=".xvpics" --exclude="*.compiled" \
+               --exclude="killme*" --exclude=".gdb_hist*" \
+               --exclude="debian"  --exclude="COPYING*" \
+               --exclude="*.app" \
+               "${S}" "${ED%/}"/usr/share \
+               || die "Unable to copy files!"
+
+       dosym ../share/lazarus/startlazarus /usr/bin/startlazarus
+       dosym ../share/lazarus/startlazarus /usr/bin/lazarus
+       dosym ../share/lazarus/lazbuild /usr/bin/lazbuild
+       use minimal || dosym ../share/lazarus/components/chmhelp/lhelp/lhelp /usr/bin/lhelp
+       dosym ../lazarus/images/ide_icon48x48.png /usr/share/pixmaps/lazarus.png
+
+       make_desktop_entry startlazarus "Lazarus IDE" "lazarus"
+}