Updated README.dev, with gentoo specific instructions
authorfuzzyray <fuzzyray@gentoo.org>
Wed, 9 Dec 2009 20:07:50 +0000 (20:07 -0000)
committerfuzzyray <fuzzyray@gentoo.org>
Wed, 9 Dec 2009 20:07:50 +0000 (20:07 -0000)
svn path=/trunk/gentoolkit/; revision=709

README.dev

index 7a33d1cb25a3a45750935872d6dc4cc7fe19b31a..feefe47a50cea15f1802c07c62d11309689bba31 100644 (file)
@@ -12,14 +12,29 @@ pylint --rcfile=pylintrc yourfile.py
 
 Creating a release:
 ===================
+Note: We are using VERSION="0.3.0" simply as an example.
+
 - Run Gentoolkit's test suite, make sure it passes:
+Note: requires dev-python/snakeoil
 ./setup.py test
+
 - Create a tag for the release
+svn copy svn+ssh://<dev>@svn.gentoo.org/var/svnroot/gentoolkit/trunk \
+         svn+ssh://<dev>@svn.gentoo.org/var/svnroot/gentoolkit/tags/gentoolkit-0.3.0 \
+        -m "Tagging the <VERSION> release of gentoolkit."
+svn update to pull the tag from subversion
+cd to the local tags/gentoolkit-0.3.0 directory
+
 - Set the version of the release:
-VERSION="0.3.0" ./setup set_version
+VERSION="0.3.0" ./setup.py set_version
+
 - Create a source distribution (you need to add VERSION here, too):
 VERSION="0.3.0" ./setup.py sdist
+Transfer dist/gentoolkit-0.3.0.tar.gz to dev.gentoo.org:/space/distfiles-local
+
 - Reset svn version to 'svn' (default):
 ./setup.py set_version
+
 - Clean up temporary files:
-./setup clean -a
+./setup.py clean -a
+