2.1.2_rc3-r4 revbump just to fix bug #157897. This patch fixes a KeyError exception...
authorZac Medico <zmedico@gentoo.org>
Tue, 12 Dec 2006 12:22:22 +0000 (12:22 +0000)
committerZac Medico <zmedico@gentoo.org>
Tue, 12 Dec 2006 12:22:22 +0000 (12:22 +0000)
Package-Manager: portage-2.1.2_rc3-r4

sys-apps/portage/ChangeLog
sys-apps/portage/files/bug_157897.patch [new file with mode: 0644]
sys-apps/portage/files/digest-portage-2.1.2_rc3-r4 [new file with mode: 0644]
sys-apps/portage/portage-2.1.2_rc3-r4.ebuild [new file with mode: 0644]

index 110bf10dbb4cbac643c0306a7ce10ae84af399ef..222468ea1cb781b2986c27d8b1f7513f7917f374 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for sys-apps/portage
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.314 2006/12/12 05:24:37 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.315 2006/12/12 12:22:22 zmedico Exp $
+
+*portage-2.1.2_rc3-r4 (12 Dec 2006)
+
+  12 Dec 2006; Zac Medico <zmedico@gentoo.org> +files/bug_157897.patch,
+  -portage-2.1.2_rc3-r3.ebuild, +portage-2.1.2_rc3-r4.ebuild:
+  2.1.2_rc3-r4 revbump just to fix bug #157897. This patch fixes a KeyError
+  exception may occur when emerge is calculating dependencies.
 
 *portage-2.1.2_rc3-r3 (12 Dec 2006)
 
diff --git a/sys-apps/portage/files/bug_157897.patch b/sys-apps/portage/files/bug_157897.patch
new file mode 100644 (file)
index 0000000..cacf214
--- /dev/null
@@ -0,0 +1,13 @@
+Index: bin/emerge
+===================================================================
+--- bin/emerge (revision 5278)
++++ bin/emerge (revision 5279)
+@@ -961,7 +961,7 @@
+                       self.digraph.addnode(jbigkey, myparent,
+                               priority=priority)
+-              if addme:
++              if mybigkey[-1] == "merge":
+                       self.mydbapi[myroot].cpv_inject(mykey,
+                               metadata=dict(izip(self._mydbapi_keys,
+                               mydbapi.aux_get(mykey, self._mydbapi_keys))))
diff --git a/sys-apps/portage/files/digest-portage-2.1.2_rc3-r4 b/sys-apps/portage/files/digest-portage-2.1.2_rc3-r4
new file mode 100644 (file)
index 0000000..096cddc
--- /dev/null
@@ -0,0 +1,9 @@
+MD5 13cffdb3558bdf90ba80a7b5eb59a2c7 portage-2.1.2_rc3-r3.patch.bz2 11231
+RMD160 6cbd9b86e7929c47d95bc372b473cba4680270e3 portage-2.1.2_rc3-r3.patch.bz2 11231
+SHA256 efa4659b013e0ae0a68e1091907372d9f8f7342afb0dea799f958dde63cb6ed0 portage-2.1.2_rc3-r3.patch.bz2 11231
+MD5 2fb183cd39a87178d3772a938dd06223 portage-2.1.2_rc3.tar.bz2 334999
+RMD160 98af2da9c8e698fe511d53c604c4c2b7703812cd portage-2.1.2_rc3.tar.bz2 334999
+SHA256 547d4d3be34eeea555ea7b1b87bc0f51aef9d4099767d232a79086acdeacf862 portage-2.1.2_rc3.tar.bz2 334999
+MD5 624d18249325e364c13dc7ef7647f986 portage-man-pl-2.1.2_rc1.tar.bz2 53030
+RMD160 9ed9037256f3eba59600028f2d8f78792a33383a portage-man-pl-2.1.2_rc1.tar.bz2 53030
+SHA256 1d03dbfab182397a9fd739604ab526b644e07b9de397f029ea3e7f6969ed1e5a portage-man-pl-2.1.2_rc1.tar.bz2 53030
diff --git a/sys-apps/portage/portage-2.1.2_rc3-r4.ebuild b/sys-apps/portage/portage-2.1.2_rc3-r4.ebuild
new file mode 100644 (file)
index 0000000..80ce9c2
--- /dev/null
@@ -0,0 +1,240 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.2_rc3-r4.ebuild,v 1.1 2006/12/12 12:22:22 zmedico Exp $
+
+inherit toolchain-funcs eutils flag-o-matic
+
+DESCRIPTION="The Portage Package Management System. The primary package management and distribution system for Gentoo."
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+PROVIDE="virtual/portage"
+SLOT="0"
+# USE_EXPAND_HIDDEN hides ELIBC and USERLAND expansions from emerge output (see make.conf.5).
+IUSE_ELIBC="elibc_glibc elibc_uclibc elibc_FreeBSD"
+IUSE_USERLAND="userland_Darwin userland_GNU"
+IUSE="build doc epydoc selinux linguas_pl ${IUSE_ELIBC} ${IUSE_USERLAND}"
+DEPEND=">=dev-lang/python-2.3
+       !build? ( >=sys-apps/sed-4.0.5 )
+       epydoc? ( >=dev-python/epydoc-2.0 )"
+RDEPEND=">=dev-lang/python-2.3
+       !build? ( >=sys-apps/sed-4.0.5
+               dev-python/python-fchksum
+               !userland_Darwin? ( >=app-shells/bash-3.0 ) )
+       elibc_glibc? ( >=sys-apps/sandbox-1.2.17 )
+       elibc_uclibc? ( >=sys-apps/sandbox-1.2.17 )
+       !userland_Darwin? ( >=app-misc/pax-utils-0.1.13 )
+       selinux? ( >=dev-python/python-selinux-2.16 )
+       doc? ( app-portage/portage-manpages )
+       >=dev-python/pycrypto-2.0.1-r5"
+SRC_ARCHIVES="http://dev.gentoo.org/~zmedico/portage/archives"
+
+PV_PL="2.1.2_rc1"
+PATCHVER_PL=""
+SRC_URI="mirror://gentoo/${PN}-${PV}.tar.bz2
+       ${SRC_ARCHIVES}/${PN}-${PV}.tar.bz2
+       linguas_pl? ( mirror://gentoo/${PN}-man-pl-${PV_PL}.tar.bz2
+       ${SRC_ARCHIVES}/${PN}-man-pl-${PV_PL}.tar.bz2 )"
+
+PATCHVER="-r3"
+#[ "${PR}" != "r0" ] && PATCHVER="-${PR}"
+if [ -n "${PATCHVER}" ]; then
+       SRC_URI="${SRC_URI} mirror://gentoo/${PN}-${PV}${PATCHVER}.patch.bz2
+       ${SRC_ARCHIVES}/${PN}-${PV}${PATCHVER}.patch.bz2"
+fi
+
+if [ -n "${PATCHVER_PL}" ]; then
+       SRC_URI="${SRC_URI} linguas_pl? ( mirror://gentoo/${PN}-man-pl-${PV_PL}${PATCHVER_PL}.patch.bz2
+       ${SRC_ARCHIVES}/${PN}-man-pl-${PV_PL}${PATCHVER_PL}.patch.bz2 )"
+fi
+
+S="${WORKDIR}"/${PN}-${PV}
+S_PL="${WORKDIR}"/${PN}-${PV_PL}
+
+portage_docs() {
+       elog ""
+       elog "For help with using portage please consult the Gentoo Handbook"
+       elog "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
+       elog ""
+}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       if [ -n "${PATCHVER}" ]; then
+               cd "${S}"
+               epatch "${WORKDIR}/${PN}-${PV}${PATCHVER}.patch"
+               epatch "${FILESDIR}"/bug_157897.patch
+       fi
+       if [ "${PR}" != "r0" ]; then
+               elog "Setting portage.VERSION to ${PVR} ..."
+               sed -i "s/^VERSION=.*/VERSION=\"${PVR}\"/" pym/portage.py || \
+                       die "Failed to patch portage.VERSION"
+               eend 0
+       fi
+       if [ -n "${PATCHVER_PL}" ]; then
+               use linguas_pl && \
+                       epatch "${WORKDIR}/${PN}-man-pl-${PV_PL}${PATCHVER_PL}.patch"
+       fi
+}
+
+src_compile() {
+       append-lfs-flags
+
+       cd "${S}"/src
+       $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o tbz2tool tbz2tool.c || \
+               die "Failed to build tbz2tool"
+
+       if use elibc_FreeBSD; then
+               cd "${S}"/src/bsd-flags
+               chmod +x setup.py
+               ./setup.py build || die "Failed to install bsd-chflags module"
+       fi
+
+       if use epydoc; then
+               mkdir "${WORKDIR}"/api
+               local my_modules
+               my_modules="$(find "${S}/pym" -name "*.py" \
+                       | sed -e 's:.*__init__.py$::' -e 's:\.py$::' -e "s:^${S}/pym/::" \
+                        -e 's:/:.:g')" || die "error listing modules"
+               PYTHONPATH="${S}/pym:${PYTHONPATH}" epydoc -o "${WORKDIR}"/api \
+                       -qqqqq --ignore-param-mismatch ${my_modules} || die "epydoc failed"
+       fi
+}
+
+src_test() {
+       local test_runner="./tests/runTests"
+       chmod +x ${test_runner}
+       PYTHONPATH="${S}:${S}/pym:${PYTHONPATH}" ${test_runner} || \
+               die "test(s) failed"
+}
+
+src_install() {
+       local portage_base="/usr/lib/portage"
+       cd "${S}"/cnf
+       insinto /etc
+       doins etc-update.conf dispatch-conf.conf make.globals
+       if [ -f "make.conf.${ARCH}".diff ]; then
+               patch make.conf "make.conf.${ARCH}".diff || \
+                       die "Failed to patch make.conf.example"
+               newins make.conf make.conf.example
+       else
+               eerror ""
+               eerror "Portage does not have an arch-specific configuration for this arch."
+               eerror "Please notify the arch maintainer about this issue. Using generic."
+               eerror ""
+               newins make.conf make.conf.example
+       fi
+
+       if use elibc_FreeBSD; then
+               cd "${S}"/src/bsd-flags
+               ./setup.py install --root "${D}" || \
+                       die "Failed to install bsd-chflags module"
+       fi
+
+       dodir ${portage_base}/bin
+       exeinto ${portage_base}/bin
+       # BSD and OSX need a sed wrapper so that find/xargs work properly
+       if use userland_GNU; then
+               rm "${S}"/bin/sed || die "Failed to remove sed wrapper"
+       fi
+       cd "${S}"/bin
+       doexe *
+       doexe "${S}"/src/tbz2tool
+       dosym newins ${portage_base}/bin/donewins
+
+       for mydir in pym pym/cache pym/elog_modules; do
+               dodir ${portage_base}/${mydir}
+               insinto ${portage_base}/${mydir}
+               cd "${S}"/${mydir}
+               doins *.py
+       done
+
+       doman "${S}"/man/*.[0-9]
+       if use linguas_pl; then
+               doman -i18n=pl "${S_PL}"/man/pl/*.[0-9]
+               doman -i18n=pl_PL.UTF-8 "${S_PL}"/man/pl_PL.UTF-8/*.[0-9]
+       fi
+       dodoc "${S}"/ChangeLog
+       dodoc "${S}"/NEWS
+       dodoc "${S}"/RELEASE-NOTES
+       use epydoc && dohtml -r "${WORKDIR}"/api
+
+       dodir /usr/bin
+       for x in ebuild emerge portageq repoman tbz2tool xpak; do
+               dosym ../lib/portage/bin/${x} /usr/bin/${x}
+       done
+
+       dodir /usr/sbin
+       local my_syms="archive-conf
+               dispatch-conf
+               emaint
+               emerge-webrsync
+               env-update
+               etc-update
+               fixpackages
+               quickpkg
+               regenworld"
+       local x
+       for x in ${my_syms}; do
+               dosym ../lib/portage/bin/${x} /usr/sbin/${x}
+       done
+
+       dodir /etc/portage
+       keepdir /etc/portage
+
+       doenvd "${FILESDIR}"/05portage.envd
+}
+
+pkg_preinst() {
+       local portage_base="/usr/lib/portage"
+       if has livecvsportage ${FEATURES} && [ "${ROOT}" = "/" ]; then
+               rm -rf "${IMAGE}"/${portage_base}/pym/*
+               mv "${IMAGE}"/${portage_base}/bin/tbz2tool "${T}"
+               rm -rf "${IMAGE}"/${portage_base}/bin/*
+               mv "${T}"/tbz2tool "${IMAGE}"/${portage_base}/bin/
+       else
+               for mydir in bin pym pym/cache pym/elog_modules; do
+                       rm "${ROOT}"/${portage_base}/${mydir}/*.pyc >& /dev/null
+                       rm "${ROOT}"/${portage_base}/${mydir}/*.pyo >& /dev/null
+               done
+       fi
+}
+
+pkg_postinst() {
+       local x
+
+       if [ ! -f "${ROOT}/var/lib/portage/world" ] &&
+          [ -f "${ROOT}"/var/cache/edb/world ] &&
+          [ ! -h "${ROOT}"/var/cache/edb/world ]; then
+               mv "${ROOT}"/var/cache/edb/world "${ROOT}"/var/lib/portage/world
+               ln -s ../../lib/portage/world /var/cache/edb/world
+       fi
+
+       for x in "${ROOT}"/etc/._cfg????_make.globals; do
+               # Overwrite the globals file automatically.
+               [ -e "${x}" ] && mv -f "${x}" "${ROOT}etc/make.globals"
+       done
+
+       ewarn "In portage-2.1.2, installation actions do not necessarily pull in build time"
+       ewarn "dependencies that are not strictly required.  This behavior is adjustable"
+       ewarn "via the new --with-bdeps option that is documented in the emerge(1) man page."
+       ewarn "For more information regarding this change, please refer to bug #148870."
+       echo
+       ewarn "In portage-2.1.2_rc2, the implicit RDEPEND behavior has been reverted back to"
+       ewarn "the way it was in <portage-2.0.52. This change restricts implicit RDEPEND to"
+       ewarn "the ebuild level, making it independent of whatever RDEPEND may or may not be"
+       ewarn "defined in the inherited eclasses.  As a result, some ebuilds will get"
+       ewarn "implicit RDEPEND that they did not get previously.  Also, some ebuilds will"
+       ewarn "loose some implicit RDEPEND that they previously got from eclasses.  Users"
+       ewarn "that sync with the rsync mirrors will have their metadata cache automatically"
+       ewarn "updated on the next sync (or the next time that they run"
+       ewarn "\`emerge --metadata\`).  Users of the gentoo-x86 CVS repository, in order to"
+       ewarn "make the change immediately effective, will have to manually remove the"
+       ewarn "entire contents of /var/cache/edb/dep/ and then run \`emerge --regen\`."
+       ewarn "If necessary, please refer to bug #153591 for more information."
+       echo
+       elog "See NEWS and RELEASE-NOTES for further changes."
+       echo
+       portage_docs
+}