dev-libs/efl: bump to 1.22.2
authorJoonas Niilola <juippis@gmail.com>
Sat, 4 May 2019 06:42:18 +0000 (09:42 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 8 May 2019 16:59:35 +0000 (18:59 +0200)
Package-Manager: Portage-2.3.64, Repoman-2.3.12
Signed-off-by: Joonas Niilola <juippis@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/11891
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/efl/Manifest
dev-libs/efl/efl-1.22.2.ebuild [new file with mode: 0644]

index 23a1a944e031c24764a1f10699031e25be8f9353..c8662382e70d9675e036c76e759d72fd68195db4 100644 (file)
@@ -1,3 +1,4 @@
 DIST efl-1.20.7.tar.xz 65509444 BLAKE2B f58f7daf850ef9983fe4b3a10a3ceb137be7f7ae32c71f476498f677de690bfcc7c16aea5032168a42aa6b5f97d1fb5ca51dafc69d80e2a9262f4d78220a8562 SHA512 c1bf18b74316cf9bd0bc16635c216ca0d8005b2ded1c014b22590388e37368343e5e5318f526dcb042cfce8ab2c7a82655e4718cbcac5dd1ed0d2522a7a2d7de
 DIST efl-1.21.1.tar.xz 71168368 BLAKE2B 4653e97f7b9a824d8e84dd1463dd6c95c0228bb3a03df1915f604136380343ad52e86e6b485f0aa14f1caef5a36451425b79cf2a5123c83d8e8a6d430ff213bf SHA512 1e26a57fca84ec85e45d707ee57abc50bd18edfa82e478e586300b6ad5ab8b9103a54a656902d29d80425988a6116a40aa01758fb8dd581dd48334ca0f4d5a63
 DIST efl-1.22.1.tar.xz 71314132 BLAKE2B 6222797da4815c7f863ff2a91b167fc78198b349d54948544b2c2bd19269836e48c343e782bf18a6eb3aeb92248a35590117ccb40f6a6f76978283a05ec41184 SHA512 2a961e2d36458e0f1f6a6b66fdd02b040590e130d9098f64e99d2fb29fa19bb292e92ab7ab8224223c186a256b3ffe7716ab218acd891a01fa9e4652c0e99230
+DIST efl-1.22.2.tar.xz 71320272 BLAKE2B b1eb66228ec5a92f5d89bf38d95439f9bfb0b09a074e418094474d7c7d0de6a4ae998321a02273a5c9bbcfcba260a7ff3d8cef0af445293869c82c57dec2cca0 SHA512 7385b1fdeee0a4565a0765fedbe5cecca81b86b306ee95a703b3064a88427ab0b4967f6f075a92f5c1d5911cefc56a9c2d45c7347572480169e3f53348321734
diff --git a/dev-libs/efl/efl-1.22.2.ebuild b/dev-libs/efl/efl-1.22.2.ebuild
new file mode 100644 (file)
index 0000000..dce1d89
--- /dev/null
@@ -0,0 +1,281 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pax-utils xdg-utils
+
+DESCRIPTION="Enlightenment Foundation Libraries all-in-one package"
+HOMEPAGE="https://www.enlightenment.org"
+SRC_URI="https://download.enlightenment.org/rel/libs/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="+bmp dds connman debug drm +eet elogind examples fbcon +fontconfig fribidi gif gles2 glib gnutls gstreamer harfbuzz hyphen +ico ibus jpeg2k libressl libuv luajit neon nls opengl ssl pdf physics postscript +ppm +psd pulseaudio raw scim sdl sound static-libs svg +system-lz4 systemd tga tiff tslib unwind v4l valgrind vlc vnc wayland webp X xcf xim xine xpm xpresent zeroconf"
+
+REQUIRED_USE="
+       ?? ( elogind systemd )
+       ?? ( gles2 opengl )
+       fbcon? ( !tslib )
+       gles2? (
+               || ( wayland X )
+               !sdl
+       )
+       ibus? ( glib )
+       opengl? ( X )
+       pulseaudio? ( sound )
+       sdl? ( opengl )
+       vnc? ( fbcon X )
+       wayland? ( gles2 !opengl )
+       xim? ( X )
+       xpresent? ( X )
+"
+
+RDEPEND="
+       net-misc/curl
+       media-libs/libpng:0=
+       sys-apps/dbus
+       sys-apps/util-linux
+       virtual/jpeg:0=
+       connman? ( net-misc/connman )
+       drm? (
+               dev-libs/libinput
+               media-libs/mesa[gbm]
+               x11-libs/libdrm
+               x11-libs/libxkbcommon
+       )
+       elogind? ( sys-auth/elogind )
+       fontconfig? ( media-libs/fontconfig )
+       fribidi? ( dev-libs/fribidi )
+       gif? ( media-libs/giflib:= )
+       gles2? ( media-libs/mesa[egl,gles2] )
+       glib? ( dev-libs/glib:2 )
+       gstreamer? (
+               media-libs/gstreamer:1.0
+               media-libs/gst-plugins-base:1.0
+       )
+       harfbuzz? ( media-libs/harfbuzz )
+       hyphen? ( dev-libs/hyphen )
+       ibus? ( app-i18n/ibus )
+       jpeg2k? ( media-libs/openjpeg:= )
+       libuv? ( dev-libs/libuv )
+       luajit? ( dev-lang/luajit:= )
+       !luajit? ( dev-lang/lua:* )
+       nls? ( sys-devel/gettext )
+       pdf? ( app-text/poppler:=[cxx] )
+       physics? ( sci-physics/bullet:= )
+       postscript? ( app-text/libspectre )
+       pulseaudio? ( media-sound/pulseaudio )
+       raw? ( media-libs/libraw:= )
+       scim? ( app-i18n/scim )
+       sdl? (
+               media-libs/libsdl2
+               virtual/opengl
+       )
+       sound? ( media-libs/libsndfile )
+       ssl? (
+               gnutls? ( net-libs/gnutls:= )
+               !gnutls? (
+                       !libressl? ( dev-libs/openssl:0= )
+                       libressl? ( dev-libs/libressl:= )
+               )
+       )
+       svg? (
+               gnome-base/librsvg
+               x11-libs/cairo
+       )
+       system-lz4? ( app-arch/lz4 )
+       systemd? ( sys-apps/systemd:= )
+       tiff? ( media-libs/tiff:0= )
+       tslib? ( x11-libs/tslib:= )
+       unwind? ( sys-libs/libunwind )
+       valgrind? ( dev-util/valgrind )
+       vlc? ( media-video/vlc )
+       vnc? ( net-libs/libvncserver )
+       wayland? (
+               dev-libs/wayland
+               media-libs/mesa[gles2,wayland]
+               x11-libs/libxkbcommon
+       )
+       webp? ( media-libs/libwebp:= )
+       X? (
+               media-libs/freetype
+               x11-libs/libXcursor
+               x11-libs/libX11
+               x11-libs/libXcomposite
+               x11-libs/libXdamage
+               x11-libs/libXext
+               x11-libs/libXfixes
+               x11-libs/libXinerama
+               x11-libs/libXrandr
+               x11-libs/libXrender
+               x11-libs/libXtst
+               x11-libs/libXScrnSaver
+               gles2? (
+                       x11-libs/libX11
+                       x11-libs/libXrender
+                       virtual/opengl
+               )
+               opengl? (
+                       x11-libs/libX11
+                       x11-libs/libXrender
+                       virtual/opengl
+               )
+       )
+       xine? ( media-libs/xine-lib )
+       xpm? ( x11-libs/libXpm )
+       xpresent? ( x11-libs/libXpresent )
+       zeroconf? ( net-dns/avahi )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+       default
+
+       # Upstream still doesnt offer a configure flag. #611108
+       if ! use unwind ; then
+               sed -i -e 's:libunwind libunwind-generic:xxxxxxxxxxxxxxxx:' \
+               configure || die "Sedding configure file with unwind fix failed."
+       fi
+}
+
+src_configure() {
+       local myconf=(
+               --enable-cxx-bindings
+               --enable-image-loader-generic
+               --enable-image-loader-jpeg
+               --enable-image-loader-png
+               --enable-libeeze
+               --enable-libmount
+               --enable-quick-launch
+               --enable-threads
+               --enable-xinput22
+
+               --disable-cancel-ok
+               --disable-cocoa
+               --disable-csharp-beta
+               --disable-csharp-bindings
+               --disable-doc
+               --disable-ecore-buffer
+               --disable-ecore-drm
+               --disable-ecore-wayland
+               --disable-eglfs
+               --disable-g-main-loop
+               --disable-gesture
+               --disable-gstreamer
+               --disable-pixman
+               --disable-tizen
+               --disable-wayland-ivi-shell
+
+               $(use_enable bmp image-loader-bmp)
+               $(use_enable bmp image-loader-wbmp)
+               $(use_enable dds image-loader-dds)
+               $(use_enable drm)
+               $(use_enable drm elput)
+               $(use_enable eet image-loader-eet)
+               $(use_enable elogind)
+               $(use_enable examples always-build-examples)
+               $(use_enable fbcon fb)
+               $(use_enable fontconfig)
+               $(use_enable fribidi)
+               $(use_enable gif image-loader-gif)
+               $(use_enable gles2 egl)
+               $(use_enable gstreamer gstreamer1)
+               $(use_enable harfbuzz)
+               $(use_enable hyphen)
+               $(use_enable ico image-loader-ico)
+               $(use_enable ibus)
+               $(use_enable jpeg2k image-loader-jp2k)
+               $(use_enable libuv)
+               $(use_enable !luajit lua-old)
+               $(use_enable neon)
+               $(use_enable nls)
+               $(use_enable pdf poppler)
+               $(use_enable physics)
+               $(use_enable postscript spectre)
+               $(use_enable ppm image-loader-pmaps)
+               $(use_enable psd image-loader-psd)
+               $(use_enable pulseaudio)
+               $(use_enable raw libraw)
+               $(use_enable scim)
+               $(use_enable sdl)
+               $(use_enable sound audio)
+               $(use_enable static-libs static)
+               $(use_enable svg librsvg)
+               $(use_enable system-lz4 liblz4)
+               $(use_enable systemd)
+               $(use_enable tga image-loader-tga)
+               $(use_enable tiff image-loader-tiff)
+               $(use_enable tslib)
+               $(use_enable v4l v4l2)
+               $(use_enable valgrind)
+               $(use_enable vlc libvlc)
+               $(use_enable vnc vnc-server)
+               $(use_enable wayland)
+               $(use_enable webp image-loader-webp)
+               $(use_enable xcf)
+               $(use_enable xim)
+               $(use_enable xine)
+               $(use_enable xpm image-loader-xpm)
+               $(use_enable xpresent)
+               $(use_enable zeroconf avahi)
+
+               --with-crypto=$(usex gnutls gnutls $(usex ssl openssl none))
+               --with-glib=$(usex glib)
+               --with-js=none
+               --with-net-control=$(usex connman connman none)
+               --with-profile=$(usex debug debug release)
+               --with-x11=$(usex X xlib none)
+
+               $(use_with X x)
+       )
+
+       use drm && use wayland && myconf+=( --enable-gl-drm )
+
+       if use opengl ; then
+               myconf+=( --with-opengl=full )
+       elif use gles2 ; then
+               myconf+=( --with-opengl=es )
+       elif use drm && use wayland ; then
+               myconf+=( --with-opengl=es )
+       else
+               myconf+=( --with-opengl=none )
+       fi
+
+       econf "${myconf[@]}"
+}
+
+src_compile() {
+       if host-is-pax && use luajit ; then
+               # We need to build the lua code first so we can pax-mark it. #547076
+               local target='_e_built_sources_target_gogogo_'
+               printf '%s: $(BUILT_SOURCES)\n' "${target}" >> src/Makefile || die
+               emake -C src "${target}"
+               emake -C src bin/elua/elua
+               pax-mark m src/bin/elua/.libs/elua
+       fi
+
+       V=1 emake
+}
+
+src_install() {
+       V=1 emake install DESTDIR="${D}"
+       einstalldocs
+
+       if ! use static-libs ; then
+               find "${D}" -name '*.la' -delete || die
+       fi
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}