dev-php/pecl-propro: add PHP 7.3 support
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 7 Jun 2019 13:33:48 +0000 (15:33 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 7 Jun 2019 14:08:10 +0000 (16:08 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-php/pecl-propro/pecl-propro-2.1.0.ebuild

index 1c8c99bad920078b78fc7dcbe2580e8bf8fd61de..ba645a7a2b180a44991d6c855f8c813d245b1c98 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="6"
+EAPI="7"
 
 PHP_EXT_NAME="propro"
 PHP_EXT_INI="yes"
@@ -9,12 +9,12 @@ PHP_EXT_ZENDEXT="no"
 PHP_EXT_ECONF_ARGS=""
 PHP_INI_NAME="30-${PHP_EXT_NAME}"
 
-USE_PHP="php5-6 php7-0 php7-1 php7-2"
+USE_PHP="php5-6 php7-1 php7-2 php7-3"
 
 inherit php-ext-pecl-r3
 
 # Only really build for 7.x
-USE_PHP="php7-0 php7-1 php7-2"
+USE_PHP="php7-1 php7-2 php7-3"
 
 KEYWORDS="~amd64 ~x86"
 
@@ -26,7 +26,7 @@ IUSE=""
 RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"
 
 src_prepare() {
-       if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
                php-ext-source-r3_src_prepare
        else
                default_src_prepare
@@ -34,7 +34,7 @@ src_prepare() {
 }
 
 src_install() {
-       if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
                php-ext-pecl-r3_src_install
        fi
 }