net-libs/qxmpp: Disable failing test
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 3 Feb 2018 13:53:36 +0000 (14:53 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 3 Feb 2018 14:00:58 +0000 (15:00 +0100)
Also cleanup src_prepare. Maintainer timeout.

Closes: https://bugs.gentoo.org/623708
Package-Manager: Portage-2.3.24, Repoman-2.3.6

net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild
net-libs/qxmpp/qxmpp-9999.ebuild

index c8b090dafc1867a381efebd8330684b47642e110..a8bd6e94ae7ddf073831e78c7156828c7ab723a7 100644 (file)
@@ -27,21 +27,25 @@ DEPEND="${RDEPEND}
        test? ( dev-qt/qttest:5 )
 "
 
-src_prepare(){
+src_prepare() {
+       default
+
        if ! use doc; then
-               sed -i \
-                       -e '/SUBDIRS/s/doc//' \
+               sed -e '/SUBDIRS/s/doc//' \
                        -e '/INSTALLS/d' \
-                       qxmpp.pro || die "sed for removing docs failed"
+                       -i qxmpp.pro || die "failed to remove docs"
        fi
        if ! use test; then
-               sed -i -e '/SUBDIRS/s/tests//' \
-                       qxmpp.pro || die "sed for removing tests failed"
+               sed -e '/SUBDIRS/s/tests//' \
+                       -i qxmpp.pro || die "failed to remove tests"
+       else
+               # requires network connection, bug #623708
+               sed -e "/qxmppiceconnection/d" \
+                       -i tests/tests.pro || die "failed to drop single test"
        fi
        # There is no point in building examples. Also, they require dev-qt/qtgui
-       sed -i -e '/SUBDIRS/s/examples//' \
-                       qxmpp.pro || die "sed for removing examples failed"
-       default_src_prepare
+       sed -e '/SUBDIRS/s/examples//' \
+               -i qxmpp.pro || die "sed for removing examples failed"
 }
 
 src_configure() {
index d9226e906b6646b1cbdad74017dfb870831b17c1..fc67feb3c99a49fe3c3c1474942972ef2dac5270 100644 (file)
@@ -28,21 +28,25 @@ DEPEND="${RDEPEND}
        test? ( dev-qt/qttest:5 )
 "
 
-src_prepare(){
+src_prepare() {
+       default
+
        if ! use doc; then
-               sed -i \
-                       -e '/SUBDIRS/s/doc//' \
+               sed -e '/SUBDIRS/s/doc//' \
                        -e '/INSTALLS/d' \
-                       qxmpp.pro || die "sed for removing docs failed"
+                       -i qxmpp.pro || die "failed to remove docs"
        fi
        if ! use test; then
-               sed -i -e '/SUBDIRS/s/tests//' \
-                       qxmpp.pro || die "sed for removing tests failed"
+               sed -e '/SUBDIRS/s/tests//' \
+                       -i qxmpp.pro || die "failed to remove tests"
+       else
+               # requires network connection, bug #623708
+               sed -e "/qxmppiceconnection/d" \
+                       -i tests/tests.pro || die "failed to drop single test"
        fi
        # There is no point in building examples. Also, they require dev-qt/qtgui
-       sed -i -e '/SUBDIRS/s/examples//' \
-                       qxmpp.pro || die "sed for removing examples failed"
-       default_src_prepare
+       sed -e '/SUBDIRS/s/examples//' \
+               -i qxmpp.pro || die "sed for removing examples failed"
 }
 
 src_configure() {