sci-biology/clustalw: Modernise to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 15:16:26 +0000 (16:16 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 15:23:58 +0000 (16:23 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-biology/clustalw/clustalw-1.83-r4.ebuild [moved from sci-biology/clustalw/clustalw-1.83-r3.ebuild with 74% similarity]
sci-biology/clustalw/files/1.83-as-needed.patch

similarity index 74%
rename from sci-biology/clustalw/clustalw-1.83-r3.ebuild
rename to sci-biology/clustalw/clustalw-1.83-r4.ebuild
index 6047a08ed466ea3d416991a9ad1635d75ded838a..bf6e6a9c28c30747432e36c58b1ac7a233c70482 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
 
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
 
 DESCRIPTION="General purpose multiple alignment program for DNA and proteins"
 HOMEPAGE="http://www.embl-heidelberg.de/~seqanal/"
@@ -17,8 +17,10 @@ IUSE=""
 
 S="${WORKDIR}"/${PN}${PV}
 
+PATCHES=( "${FILESDIR}"/${PV}-as-needed.patch )
+
 src_prepare() {
-       epatch "${FILESDIR}"/${PV}-as-needed.patch
+       default
 
        sed \
                -e "/^CC/s:cc:$(tc-getCC):g" \
@@ -30,7 +32,5 @@ src_prepare() {
 
 src_install() {
        dobin clustalw
-       dodoc README clustalv.doc clustalw.doc clustalw.ms
-       insinto /usr/share/doc/${PF}
-       doins clustalw_help
+       dodoc README clustalv.doc clustalw{.doc,.ms,_help}
 }
index 62b4654cddea7e76506af13cf1f13f5962f40555..9bb35b43f24a6196306085d8d43153b69115c8fc 100644 (file)
@@ -1,5 +1,5 @@
---- makefile   2003-01-29 09:53:45.000000000 +0100
-+++ makefile.new       2009-08-17 08:33:16.000000000 +0200
+--- a/makefile
++++ b/makefile
 @@ -11,11 +11,11 @@
  HEADERS = general.h clustalw.h