sci-libs/ViSP: Fix USE=doc
authorAlexis Ballier <aballier@gentoo.org>
Mon, 25 May 2020 12:52:40 +0000 (14:52 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 25 May 2020 12:52:48 +0000 (14:52 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
sci-libs/ViSP/ViSP-3.3.0.ebuild

index f524038341b00fadc6a0c948172388764f175ac3..35b2a248ef5d87f90b733f03121800cabf5207e1 100644 (file)
@@ -84,8 +84,7 @@ src_configure() {
 
 src_compile() {
        cmake-utils_src_compile
-       cd "${BUILD_DIR}"
-       use doc && emake visp_doc
+       use doc && cmake-utils_src_compile visp_doc
 }
 
 src_install() {
@@ -95,5 +94,5 @@ src_install() {
                docompress -x /usr/share/doc/${PF}/tutorial
        fi
        cd "${BUILD_DIR}"
-       use doc && dohtml -r doc/html/*
+       use doc && dodoc -r doc/html
 }