Changed einfo to eerror, removed old version.
authorTimothy Redaelli <drizzt@gentoo.org>
Sat, 6 Jan 2007 15:31:05 +0000 (15:31 +0000)
committerTimothy Redaelli <drizzt@gentoo.org>
Sat, 6 Jan 2007 15:31:05 +0000 (15:31 +0000)
Package-Manager: portage-2.1.2_rc4-r6

net-im/ekiga/ChangeLog
net-im/ekiga/ekiga-2.0.3.ebuild

index 096b3988805005879318d9538246b154cf6a3607..c2f8c1c76b04002f861940a677736e5ee42f06ef 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for net-im/ekiga
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekiga/ChangeLog,v 1.22 2007/01/06 14:50:17 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekiga/ChangeLog,v 1.23 2007/01/06 15:31:05 drizzt Exp $
+
+  06 Jan 2007; Timothy Redaelli <drizzt@gentoo.org> -ekiga-2.0.2.ebuild,
+  ekiga-2.0.3.ebuild:
+  Changed einfo to eerror, removed old version.
 
   06 Jan 2007; Bryan Ã˜stergaard <kloeri@gentoo.org> ekiga-2.0.3.ebuild:
   Add ~ia64 keyword, bug 142482.
index 0596394fa0815e0b0bd96826723bf56dfe9e7671..28c404f11a76757da23d889c930423b6c60a75a6 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekiga/ekiga-2.0.3.ebuild,v 1.9 2007/01/06 14:50:17 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekiga/ekiga-2.0.3.ebuild,v 1.10 2007/01/06 15:31:05 drizzt Exp $
 
 inherit gnome2 eutils flag-o-matic
 
@@ -42,12 +42,12 @@ DEPEND="${RDEPEND}
 
 pkg_setup() {
        if ! built_with_use dev-libs/pwlib ldap; then
-               einfo "You need to build dev-libs/pwlib with USE=ldap enabled."
+               eerror "You need to build dev-libs/pwlib with USE=ldap enabled."
                die "Pwlib w/o ldap-support detected."
        fi
 
        if use avahi && ! built_with_use net-dns/avahi dbus; then
-               einfo "You need to build net-dns/avahi with USE=dbus enabled."
+               eerror "You need to build net-dns/avahi with USE=dbus enabled."
                die "Avahi without dbus-support detected."
        fi
 }
@@ -55,11 +55,11 @@ pkg_setup() {
 src_unpack() {
        unpack ${A}
 
-       cd ${S}
+       cd "${S}"
        # Fix configure to install schemafile into the proper directory
-       epatch ${FILESDIR}/${PN}-1.99.0-configure.patch
-       epatch ${FILESDIR}/${PN}-eggtrayicon-update.diff
-       epatch ${FILESDIR}/${PN}-eggtrayicon-transparency.diff
+       epatch "${FILESDIR}"/${PN}-1.99.0-configure.patch
+       epatch "${FILESDIR}"/${PN}-eggtrayicon-update.diff
+       epatch "${FILESDIR}"/${PN}-eggtrayicon-transparency.diff
 }
 
 src_compile() {
@@ -78,7 +78,7 @@ src_install() {
        if use gnome; then
                gnome2_src_install
        else
-               make DESTDIR=${D} install || die "make install failed"
+               make DESTDIR="${D}" install || die "make install failed"
 
                dodoc AUTHORS ChangeLog NEWS
        fi