sys-devel/prelink: drop old
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 1 Apr 2020 21:05:17 +0000 (22:05 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 1 Apr 2020 21:14:10 +0000 (22:14 +0100)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-devel/prelink/Manifest
sys-devel/prelink/prelink-20130503-r1.ebuild [deleted file]
sys-devel/prelink/prelink-20130503.ebuild [deleted file]

index c752cf61c262912bdb4d46a6b437877e9d3a60df..139e3eee1b839f56554635bcc7c1592b19bcb295 100644 (file)
@@ -1,3 +1,2 @@
-DIST prelink-20130503.tar.bz2 928040 BLAKE2B cb0e6fbff85b57c8698f22750377461e127bf89f6d03e6fab2338cc50dc280036ab5d1f56b0e8eed5ebaf391f8e3e0d3c32d9df6499fa17e2e556656ba13966d SHA512 69138a695e3e535deacd8224f6f8364ff64b8868b87b516d1f3392d9df968f77265177e9fede09c38f16aa878f9fd57a9ec39f0d9deabc0c9c01609b11156ba3
 DIST prelink-cross-20151030.tar.bz2 701337 BLAKE2B 4875b936254a03afd0eeb1ee81ee99f97a2d654b7c0379acb80ea3763412f3e892c366a9962ff3e1493bba9c83a8a140e79a1d5fb08b269a08ef596d63fd1d32 SHA512 75edd8617b95ae5bd3bfc968732ee142c968855c97c5b2b93784d3476a9724e0fd9a4eb7af681a5356616a4f023e24d5c5a2e75fb57e2a25b142cc901d9bfcaf
 DIST prelink.pdf 474129 BLAKE2B 6df5d4998d0822a8032c5dcd1103d7eafa8e9002f2cbfa8fa821131d7c804d2998100dc98d310ae3ae601137b6815435ecdd2684d547a8d25025984c20c06318 SHA512 86b7163fcf6f43d1764183b3dfc30aad8de99ce198b2721af276c81fc361e9f5fd8f4aea1e8e0c653f0566e8346dff4b4ba72909359167aa92c094f5561d2e1e
diff --git a/sys-devel/prelink/prelink-20130503-r1.ebuild b/sys-devel/prelink/prelink-20130503-r1.ebuild
deleted file mode 100644 (file)
index 5f8f8e9..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="Modifies ELFs to avoid runtime symbol resolutions resulting in faster load times"
-HOMEPAGE="https://people.redhat.com/jakub/prelink"
-
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-#SRC_URI="https://people.redhat.com/jakub/prelink/${P}.tar.bz2"
-
-# if not available on jakub's dev space extract the distfile with rpm2tarbz2 from
-# https://mirrors.kernel.org/fedora/development/rawhide/source/SRPMS/p/prelink-[ver].src.rpm
-#
-# track http://pkgs.fedoraproject.org/cgit/prelink.git/ for updates
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 -arm ~ppc ~ppc64 ~x86"
-IUSE="selinux"
-
-DEPEND=">=dev-libs/elfutils-0.100[static-libs(+)]
-       selinux? ( sys-libs/libselinux[static-libs(+)] )
-       !dev-libs/libelf
-       >=sys-libs/glibc-2.8"
-RDEPEND="${DEPEND}
-       >=sys-devel/binutils-2.18"
-
-S=${WORKDIR}/${PN}
-
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-20130503-prelink-conf.patch
-       epatch "${FILESDIR}"/${PN}-20130503-libiberty-md5.patch
-       epatch "${FILESDIR}"/${PN}-armhf-dynamic-linker.patch
-
-       sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.in || die #469126
-
-       sed -i -e '/^CC=/s: : -Wl,--disable-new-dtags :' testsuite/functions.sh #100147
-       # >=binutils-2.22 --no-copy-dt-needed-entries is the default
-       # --copy-dt-needed-entries was renamed from --add-needed in 2.21, use the
-       # former so we don't have to bump the dep
-       sed -i \
-               -e '/CCLINK=/s:CCLINK="$(CC):& -Wl,--add-needed :' \
-               -e '/CXXLINK=/s:CXXLINK="$(CXX):& -Wl,--add-needed :' \
-               testsuite/Makefile.am
-
-       has_version 'dev-libs/elfutils[threads]' && append-ldflags -pthread
-
-       eautoreconf # prevent maintainer mode
-
-       # have to do this after eautoreconf or automake barfs on the trailing
-       # backslash of the previous line
-       sed -i -e 's:undosyslibs.sh::' testsuite/Makefile.in #254201
-
-       export ac_cv_{header_selinux_selinux_h,lib_selinux_is_selinux_enabled}=$(usex selinux)
-}
-
-src_install() {
-       default
-
-       insinto /etc
-       doins doc/prelink.conf
-
-       exeinto /etc/cron.daily
-       newexe "${FILESDIR}"/prelink.cron prelink
-       newconfd "${FILESDIR}"/prelink.confd prelink
-}
-
-pkg_postinst() {
-       if [ -z "${REPLACING_VERSIONS}" ] ; then
-               elog "You may wish to read the Gentoo Linux Prelink Guide, which can be"
-               elog "found online at:"
-               elog "    https://wiki.gentoo.org/wiki/Prelink"
-               elog "Please edit /etc/conf.d/prelink to enable and configure prelink"
-       fi
-}
diff --git a/sys-devel/prelink/prelink-20130503.ebuild b/sys-devel/prelink/prelink-20130503.ebuild
deleted file mode 100644 (file)
index 46b2197..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="Modifies ELFs to avoid runtime symbol resolutions resulting in faster load times"
-HOMEPAGE="https://people.redhat.com/jakub/prelink"
-
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-#SRC_URI="https://people.redhat.com/jakub/prelink/${P}.tar.bz2"
-
-# if not available on jakub's dev space extract the distfile with rpm2tarbz2 from
-# https://mirrors.kernel.org/fedora/development/rawhide/source/SRPMS/p/prelink-[ver].src.rpm
-#
-# track http://pkgs.fedoraproject.org/cgit/prelink.git/ for updates
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 -arm ppc ppc64 x86"
-IUSE="selinux"
-
-DEPEND=">=dev-libs/elfutils-0.100[static-libs(+)]
-       selinux? ( sys-libs/libselinux[static-libs(+)] )
-       !dev-libs/libelf
-       >=sys-libs/glibc-2.8"
-RDEPEND="${DEPEND}
-       >=sys-devel/binutils-2.18"
-
-S=${WORKDIR}/${PN}
-
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-20130503-prelink-conf.patch
-       epatch "${FILESDIR}"/${PN}-20130503-libiberty-md5.patch
-       epatch "${FILESDIR}"/${PN}-armhf-dynamic-linker.patch
-
-       sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.in || die #469126
-
-       sed -i -e '/^CC=/s: : -Wl,--disable-new-dtags :' testsuite/functions.sh #100147
-       # >=binutils-2.22 --no-copy-dt-needed-entries is the default
-       # --copy-dt-needed-entries was renamed from --add-needed in 2.21, use the
-       # former so we don't have to bump the dep
-       sed -i \
-               -e '/CCLINK=/s:CCLINK="$(CC):& -Wl,--add-needed :' \
-               -e '/CXXLINK=/s:CXXLINK="$(CXX):& -Wl,--add-needed :' \
-               testsuite/Makefile.am
-
-       has_version 'dev-libs/elfutils[threads]' && append-ldflags -pthread
-
-       eautoreconf # prevent maintainer mode
-
-       # have to do this after eautoreconf or automake barfs on the trailing
-       # backslash of the previous line
-       sed -i -e 's:undosyslibs.sh::' testsuite/Makefile.in #254201
-
-       export ac_cv_{header_selinux_selinux_h,lib_selinux_is_selinux_enabled}=$(usex selinux)
-}
-
-src_install() {
-       default
-
-       insinto /etc
-       doins doc/prelink.conf
-
-       exeinto /etc/cron.daily
-       newexe "${FILESDIR}"/prelink.cron prelink
-       newconfd "${FILESDIR}"/prelink.confd prelink
-
-       dodir /var/{lib/misc,log}
-       touch "${ED}"/var/lib/misc/prelink.{full,quick,force}
-       touch "${ED}"/var/log/prelink.log
-}
-
-pkg_postinst() {
-       if [ -z "${REPLACING_VERSIONS}" ] ; then
-               elog "You may wish to read the Gentoo Linux Prelink Guide, which can be"
-               elog "found online at:"
-               elog "    https://wiki.gentoo.org/wiki/Prelink"
-               elog "Please edit /etc/conf.d/prelink to enable and configure prelink"
-       fi
-       touch "${EROOT}/var/lib/misc/prelink.force"
-}