app-editors/gedit: remove old
authorMart Raudsepp <leio@gentoo.org>
Sun, 8 Dec 2019 20:26:07 +0000 (22:26 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 8 Dec 2019 20:26:07 +0000 (22:26 +0200)
Package-Manager: Portage-2.3.79, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
app-editors/gedit/Manifest
app-editors/gedit/gedit-3.30.2.ebuild [deleted file]

index 4cb53c80c57b51562d4d345183f14d89df8ba9af..bd16ddee802e2d605a6f4f93cd57de128e992e2a 100644 (file)
@@ -1,2 +1 @@
-DIST gedit-3.30.2.tar.xz 3155628 BLAKE2B 96736adbce987af89b37a712448f42b2a2eeed72d52aa16377d961c9e929fa4e75205eac5987bfc067cc2fecb35aec720d85483c4e2e824a6e8248cc652d2fbe SHA512 58ae7a4c27aeabad670718e39e1860df112d0be00ea622cc8adc185cb5d0e16ac4af65cb3aa45423c7b1b94c88d04d081fe05f3647b054a3e3291abc73c41f6f
 DIST gedit-3.32.2.tar.xz 14789660 BLAKE2B 574a490e3beda9e8b4f8324409f3a1e3361b1fdd097c4bf8d05475be2a6bb66b230ab6d2047caa62c393458c29b6647c32293ce5c1428d030cb2345c19bf41c3 SHA512 a3ed4dea3d0f60fb2371d2b6bbf5f5db1f67c9a71d0d47836456e022903e86b8b127c88ece6a6d817b0c86ff82612c963a9e8ed60f9841af68474a1d129c886d
diff --git a/app-editors/gedit/gedit-3.30.2.ebuild b/app-editors/gedit/gedit-3.30.2.ebuild
deleted file mode 100644 (file)
index 1ef6ef9..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-GNOME2_LA_PUNT="yes" # plugins are dlopened
-PYTHON_COMPAT=( python3_{5,6} )
-VALA_MIN_API_VERSION="0.26"
-VALA_USE_DEPEND="vapigen"
-
-inherit eutils gnome2 multilib python-single-r1 vala virtualx
-
-DESCRIPTION="A text editor for the GNOME desktop"
-HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
-
-LICENSE="GPL-2+ CC-BY-SA-3.0"
-SLOT="0"
-
-IUSE="+introspection +python spell vala"
-REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
-
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc x86 ~amd64-linux ~x86-linux"
-
-# X libs are not needed for OSX (aqua)
-COMMON_DEPEND="
-       >=dev-libs/libxml2-2.5.0:2
-       >=dev-libs/glib-2.44:2[dbus]
-       >=x11-libs/gtk+-3.22.0:3[introspection?]
-       >=x11-libs/gtksourceview-3.22.0:3.0[introspection?]
-       >=dev-libs/libpeas-1.14.1[gtk]
-
-       gnome-base/gsettings-desktop-schemas
-       gnome-base/gvfs
-
-       x11-libs/libX11
-
-       introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
-       python? (
-               ${PYTHON_DEPS}
-               dev-python/pycairo[${PYTHON_USEDEP}]
-               >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
-               dev-libs/libpeas[python,${PYTHON_USEDEP}] )
-       spell? ( >=app-text/gspell-0.2.5:0= )
-"
-RDEPEND="${COMMON_DEPEND}
-       x11-themes/adwaita-icon-theme
-"
-DEPEND="${COMMON_DEPEND}
-       ${vala_depend}
-       app-text/docbook-xml-dtd:4.1.2
-       dev-util/glib-utils
-       >=dev-util/gtk-doc-am-1
-       >=dev-util/intltool-0.50.1
-       dev-util/itstool
-       >=sys-devel/gettext-0.18
-       virtual/pkgconfig
-"
-# yelp-tools, gnome-common needed to eautoreconf
-
-pkg_setup() {
-       use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
-       vala_src_prepare
-       gnome2_src_prepare
-}
-
-src_configure() {
-       DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
-
-       gnome2_src_configure \
-               --disable-deprecations \
-               --disable-updater \
-               --enable-gvfs-metadata \
-               $(use_enable introspection) \
-               $(use_enable spell) \
-               $(use_enable python) \
-               $(use_enable vala)
-}
-
-src_test() {
-       "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
-       GSETTINGS_SCHEMA_DIR="${S}/data" virtx emake check
-}
-
-src_install() {
-       local args=()
-       # manually set pyoverridesdir due to bug #524018 and AM_PATH_PYTHON limitations
-       use python && args+=( pyoverridesdir="$(python_get_sitedir)/gi/overrides" )
-
-       gnome2_src_install "${args[@]}"
-}