media-libs/mesa: check for CONFIG_CHECKPOINT_RESTORE=y
authorIlya Trukhanov <lahvuun@gmail.com>
Sat, 23 May 2020 14:13:15 +0000 (17:13 +0300)
committerMatt Turner <mattst88@gentoo.org>
Sun, 24 May 2020 20:28:54 +0000 (13:28 -0700)
This lets AMDGPU users know they should enable the kernel config option.
It should be enabled by CONFIG_GENTOO_LINUX_INIT_SYSTEMD, but if e.g.
OpenRC is used, it's possible for the option to be unset, as was in
my case.

Not doing so can cause the following spooky warning:
"amdgpu: os_same_file_description couldn't determine if two DRM fds
reference the same file description. If they do, bad things may happen!"

I haven't experienced any issues with the config option disabled, but
the warning is likely there for a reason.

Closes: https://github.com/gentoo/gentoo/pull/15926
Signed-off-by: Ilya Trukhanov <lahvuun@gmail.com>
Signed-off-by: Matt Turner <mattst88@gentoo.org>
media-libs/mesa/mesa-19.3.5.ebuild
media-libs/mesa/mesa-20.0.4-r1.ebuild
media-libs/mesa/mesa-20.0.7.ebuild
media-libs/mesa/mesa-20.1.0_rc4.ebuild
media-libs/mesa/mesa-9999.ebuild

index 7773329bcc6eb35aada7e7cf940ab98507ae10d1..734d4a391c51817c3913f78254d522c37050ffa3 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python3_{6,7,8} )
 
-inherit llvm meson multilib-minimal pax-utils python-any-r1
+inherit llvm meson multilib-minimal pax-utils python-any-r1 linux-info
 
 OPENGL_DIR="xorg-x11"
 
@@ -325,6 +325,15 @@ pkg_setup() {
                ewarn "detected! This can cause problems. For details, see bug 459306."
        fi
 
+       # os_same_file_description requires the kcmp syscall,
+       # which is only available with CONFIG_CHECKPOINT_RESTORE=y.
+       # Currently only AMDGPU utilizes this function, so only AMDGPU users would
+       # get a spooky warning message if the syscall fails.
+       if use gallium && use video_cards_radeonsi; then
+               CONFIG_CHECK="~CHECKPOINT_RESTORE"
+               linux-info_pkg_setup
+       fi
+
        if use gallium && use llvm; then
                llvm_pkg_setup
        fi
index 7beeaef918f672b26d664312d1751e739fbbf280..097105ff4c5beb39919c7f01fd33408232cea667 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python3_{6,7,8} )
 
-inherit llvm meson multilib-minimal python-any-r1
+inherit llvm meson multilib-minimal python-any-r1 linux-info
 
 OPENGL_DIR="xorg-x11"
 
@@ -330,6 +330,15 @@ pkg_setup() {
                ewarn "detected! This can cause problems. For details, see bug 459306."
        fi
 
+       # os_same_file_description requires the kcmp syscall,
+       # which is only available with CONFIG_CHECKPOINT_RESTORE=y.
+       # Currently only AMDGPU utilizes this function, so only AMDGPU users would
+       # get a spooky warning message if the syscall fails.
+       if use gallium && use video_cards_radeonsi; then
+               CONFIG_CHECK="~CHECKPOINT_RESTORE"
+               linux-info_pkg_setup
+       fi
+
        if use gallium && use llvm; then
                llvm_pkg_setup
        fi
index 03083871b14d1565794849ac76dc43de89ed1499..ff719014070b5be4516821bb3874488c6045149e 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python3_{6,7,8} )
 
-inherit llvm meson multilib-minimal python-any-r1
+inherit llvm meson multilib-minimal python-any-r1 linux-info
 
 OPENGL_DIR="xorg-x11"
 
@@ -334,6 +334,15 @@ pkg_setup() {
                ewarn "detected! This can cause problems. For details, see bug 459306."
        fi
 
+       # os_same_file_description requires the kcmp syscall,
+       # which is only available with CONFIG_CHECKPOINT_RESTORE=y.
+       # Currently only AMDGPU utilizes this function, so only AMDGPU users would
+       # get a spooky warning message if the syscall fails.
+       if use gallium && use video_cards_radeonsi; then
+               CONFIG_CHECK="~CHECKPOINT_RESTORE"
+               linux-info_pkg_setup
+       fi
+
        if use gallium && use llvm; then
                llvm_pkg_setup
        fi
index 03083871b14d1565794849ac76dc43de89ed1499..ff719014070b5be4516821bb3874488c6045149e 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python3_{6,7,8} )
 
-inherit llvm meson multilib-minimal python-any-r1
+inherit llvm meson multilib-minimal python-any-r1 linux-info
 
 OPENGL_DIR="xorg-x11"
 
@@ -334,6 +334,15 @@ pkg_setup() {
                ewarn "detected! This can cause problems. For details, see bug 459306."
        fi
 
+       # os_same_file_description requires the kcmp syscall,
+       # which is only available with CONFIG_CHECKPOINT_RESTORE=y.
+       # Currently only AMDGPU utilizes this function, so only AMDGPU users would
+       # get a spooky warning message if the syscall fails.
+       if use gallium && use video_cards_radeonsi; then
+               CONFIG_CHECK="~CHECKPOINT_RESTORE"
+               linux-info_pkg_setup
+       fi
+
        if use gallium && use llvm; then
                llvm_pkg_setup
        fi
index 03083871b14d1565794849ac76dc43de89ed1499..ff719014070b5be4516821bb3874488c6045149e 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python3_{6,7,8} )
 
-inherit llvm meson multilib-minimal python-any-r1
+inherit llvm meson multilib-minimal python-any-r1 linux-info
 
 OPENGL_DIR="xorg-x11"
 
@@ -334,6 +334,15 @@ pkg_setup() {
                ewarn "detected! This can cause problems. For details, see bug 459306."
        fi
 
+       # os_same_file_description requires the kcmp syscall,
+       # which is only available with CONFIG_CHECKPOINT_RESTORE=y.
+       # Currently only AMDGPU utilizes this function, so only AMDGPU users would
+       # get a spooky warning message if the syscall fails.
+       if use gallium && use video_cards_radeonsi; then
+               CONFIG_CHECK="~CHECKPOINT_RESTORE"
+               linux-info_pkg_setup
+       fi
+
        if use gallium && use llvm; then
                llvm_pkg_setup
        fi