www-misc/buku: Add version 4.3
authorJohn Helmert III <jchelmertt3@gmail.com>
Tue, 24 Mar 2020 22:07:36 +0000 (17:07 -0500)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 5 Apr 2020 07:17:53 +0000 (10:17 +0300)
Remove support for buku-server for now.

Closes: https://bugs.gentoo.org/714590
Signed-off-by: John Helmert III <jchelmertt3@gmail.com>
Package-Manager: Portage-2.3.95, Repoman-2.3.21
Closes: https://github.com/gentoo/gentoo/pull/15096
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
www-misc/buku/Manifest
www-misc/buku/buku-4.3.ebuild [new file with mode: 0644]
www-misc/buku/metadata.xml

index 2b805aaa24e70bc3ad94fc69d184fa26ca2f83b4..fd580a993ab265b3499f7b08532f6f2b4666d902 100644 (file)
@@ -1,3 +1,4 @@
 DIST buku-3.5.tar.gz 93634 BLAKE2B 55c4b50b3bf8121c116554613768cd836080b363d702469eb2f76349c26d8d6246f73746248123030c5657006e09a9f72242354ce3af20d93b845f1870929bbc SHA512 b9f70665c83033ca030302e805ee051a524b2f0decae6c99ad54749b4a4bc91ae8261976018741361489525f359ea71c01ddb3e2d827ab9a052fb0acc98be8ed
 DIST buku-3.6.tar.gz 92012 BLAKE2B a92f45810acfb11493ca4c0ff75c57b81064627dea632bdf55ab5e33618e2721163ba0dcaa95d8cbec579605bc714d24ef894de10f4a10f3bf6ef5eb5aa42cc3 SHA512 77fabec93e85d6b6d5dbc0a3c4d095f26093f1d86aadb2a3c961a3947ac1c59acac69c94f732d30daec9943728e35d5e08bede1f0448c02d2db9136fe426186f
 DIST buku-3.7.tar.gz 98970 BLAKE2B 7227b5fb632d9ec92ef236d1889f2ba0872d67d2c3cfb302beab48b03e8d62a762d02e517014d5041a9f79deab74d0f5ceca12c315eb77922f73d359b58a48b5 SHA512 c515e11686aa8888231ffc8c1d6ec29d6143f1714eacdf640d8d3d3fa3fd469e111073762a3ba831dd673d63034afe3db181ec66501c18165e8ddd97cbc57c82
+DIST buku-4.3.tar.gz 264480 BLAKE2B 8bddf640512e5741f80bb5bc073208d843cac32d3c3ade0bdf36241e93d6c81d47238ad03c651e924226933efa572e65d9a4c86f861acda68935c9e96d6e6fb4 SHA512 eabf45b1cc1700b20f2a95baf14940f49e2a2ad51aef0f870c488e67cb07fb110916d93037830cd83572317c5d0a8b05c0a5732f105face2a14facf6af02b690
diff --git a/www-misc/buku/buku-4.3.ebuild b/www-misc/buku/buku-4.3.ebuild
new file mode 100644 (file)
index 0000000..6dcf64f
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Powerful command-line bookmark manager"
+HOMEPAGE="https://github.com/jarun/buku"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test"
+
+RDEPEND="
+       >=dev-python/beautifulsoup-4.6.0[${PYTHON_USEDEP}]
+       dev-python/cryptography[${PYTHON_USEDEP}]
+       >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
+       dev-python/urllib3[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+       test? (
+               dev-python/attrs[${PYTHON_USEDEP}]
+               >=dev-python/click-7.0[${PYTHON_USEDEP}]
+               dev-python/flake8[${PYTHON_USEDEP}]
+               dev-python/hypothesis[${PYTHON_USEDEP}]
+               >=dev-python/py-1.5.0[${PYTHON_USEDEP}]
+               >=dev-python/pylint-1.7.2[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               >=dev-python/pyyaml-4.2[${PYTHON_USEDEP}]
+               >=dev-python/vcrpy-4.0.2[${PYTHON_USEDEP}]
+       )
+"
+
+python_prepare() {
+       distutils-r1_python_prepare_all
+
+       # Remove support for bukuserver - complex depgraph which isn't all
+       # sufficiently packaged in Gentoo
+       sed -ie '/console_scripts/s/,.*/]/' setup.py || die
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       insinto /usr/share/zsh/site-functions
+       doins auto-completion/zsh/_*
+
+       newbashcomp auto-completion/bash/buku-completion.bash "${PN}"
+
+       doman buku.1
+}
+
+python_test() {
+       # Explicitly enumerate tests to avoid tests that deal with bukuserver
+       py.test -v "tests/test_"{BukuCrypt,bukuDb,buku,ExtendedArgumentParser,import_firefox_json}".py" || die
+}
index e3171793d0f6f64e4932ba162b120df0230f750d..dfaeb72ad86aef6323e6c0aaf4aab047309bee1e 100644 (file)
@@ -5,6 +5,10 @@
                <email>davidroman96@gmail.com</email>
                <name>David Roman</name>
        </maintainer>
+       <maintainer type="person">
+               <email>jchelmertt3@gmail.com</email>
+               <name>John Helmert III</name>
+       </maintainer>
        <maintainer type="project">
                <email>proxy-maint@gentoo.org</email>
                <name>Proxy Maintainers</name>