projects
/
portage.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d3c6bd5
)
dyn_spec: account for empty $FILESDIR
author
Zac Medico
<zmedico@gentoo.org>
Fri, 29 Oct 2010 09:55:19 +0000
(
02:55
-0700)
committer
Zac Medico
<zmedico@gentoo.org>
Sat, 30 Oct 2010 03:40:24 +0000
(20:40 -0700)
This should fix bug 342721.
bin/misc-functions.sh
patch
|
blob
|
history
diff --git
a/bin/misc-functions.sh
b/bin/misc-functions.sh
index b266764f9909e6877f963a5e556163cc8e9e7a09..79ce4362883b990b8fd1e0a78d309e9632d67721 100755
(executable)
--- a/
bin/misc-functions.sh
+++ b/
bin/misc-functions.sh
@@
-907,8
+907,10
@@
dyn_package() {
dyn_spec() {
local sources_dir=/usr/src/rpm/SOURCES
mkdir -p "${sources_dir}"
+ declare -a tar_args=("${EBUILD}")
+ [[ -d ${FILESDIR} ]] && tar_args=("${EBUILD}" "${FILESDIR}")
tar czf "${sources_dir}/${PF}.tar.gz" \
- "${
EBUILD}" "${FILESDIR
}" || \
+ "${
tar_args[@]
}" || \
die "Failed to create base rpm tarball."
cat <<__END1__ > ${PF}.spec