Version bump
authorChristoph Mende <angelos@gentoo.org>
Mon, 17 Oct 2011 16:53:32 +0000 (16:53 +0000)
committerChristoph Mende <angelos@gentoo.org>
Mon, 17 Oct 2011 16:53:32 +0000 (16:53 +0000)
Package-Manager: portage-2.1.10.27/cvs/Linux x86_64

media-gfx/ristretto/ChangeLog
media-gfx/ristretto/ristretto-0.2.0.ebuild [new file with mode: 0644]

index 61a1e345b169b157d858829cccfd41a2178e0efb..710e4fd7bd605e747b9edd238646b4856a4a7f44 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for media-gfx/ristretto
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/ristretto/ChangeLog,v 1.40 2011/10/16 05:26:27 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/ristretto/ChangeLog,v 1.41 2011/10/17 16:53:32 angelos Exp $
+
+*ristretto-0.2.0 (17 Oct 2011)
+
+  17 Oct 2011; Christoph Mende <angelos@gentoo.org> +ristretto-0.2.0.ebuild:
+  Version bump
 
   16 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> ristretto-0.1.0.ebuild:
   amd64 stable wrt #386963
diff --git a/media-gfx/ristretto/ristretto-0.2.0.ebuild b/media-gfx/ristretto/ristretto-0.2.0.ebuild
new file mode 100644 (file)
index 0000000..d84d861
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/ristretto/ristretto-0.2.0.ebuild,v 1.1 2011/10/17 16:53:32 angelos Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Image viewer and browser for Xfce4"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/ristretto"
+SRC_URI="mirror://xfce/src/apps/${PN}/0.2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="media-libs/libexif
+       >=x11-libs/gtk+-2.20:2
+       >=dev-libs/glib-2.24:2
+       >=dev-libs/dbus-glib-0.90
+       >=xfce-base/libxfce4util-4.8
+       >=xfce-base/libxfce4ui-4.8
+       >=xfce-base/xfconf-4.8
+       >=x11-libs/cairo-1.8"
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig
+       dev-util/intltool
+       sys-devel/gettext"
+
+pkg_setup() {
+       XFCONF=(
+               --docdir=/usr/share/doc/${PF}
+               $(xfconf_use_debug)
+               )
+
+       DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}