dev-db/myodbc Add patch from bug 548912 and fix bug 557302
authorBrian Evans <grknight@gentoo.org>
Tue, 11 Aug 2015 17:14:28 +0000 (13:14 -0400)
committerBrian Evans <grknight@gentoo.org>
Tue, 11 Aug 2015 17:14:28 +0000 (13:14 -0400)
Package-Manager: portage-2.2.20

dev-db/myodbc/files/5.2.7-my_malloc.patch [new file with mode: 0644]
dev-db/myodbc/myodbc-5.2.7-r2.ebuild

diff --git a/dev-db/myodbc/files/5.2.7-my_malloc.patch b/dev-db/myodbc/files/5.2.7-my_malloc.patch
new file mode 100644 (file)
index 0000000..bc6c65e
--- /dev/null
@@ -0,0 +1,18 @@
+diff -Brau a/util/odbcinstw.c b/util/odbcinstw.c
+--- a/util/odbcinstw.c 2014-04-23 21:54:40.000000000 +0200
++++ b/util/odbcinstw.c 2015-05-08 15:29:09.400568356 +0200
+@@ -68,13 +68,7 @@
+   if (lpszRetBuffer && cbRetBuffer)
+   {
+-    ret= malloc(cbRetBuffer + 1);
+-    /*
+-      We cannot rely on getting correct results from the next call of
+-      SQLGetPrivateProfileString. So, taking precautions against unititialized
+-      values in the allocated buffer.
+-    */
+-    memset(ret, 0, cbRetBuffer + 1);
++    ret= my_malloc(cbRetBuffer + 1, MYF(MY_ZEROFILL));
+   }
+   else
+     ret= NULL;
index cf7133d47176cbd4aa45736f0a572677a4cc3ba8..65b99da610dd5c737b79d2a60d7e786c7cf0a398 100644 (file)
@@ -44,8 +44,9 @@ src_prepare() {
 
        # Patch document path so it doesn't install files to /usr
        epatch "${FILESDIR}/cmake-doc-path.patch" \
-               "${FILESDIR}/${PVR}-cxxlinkage.patch" \
-               "${FILESDIR}/${PV}-mariadb-dynamic-array.patch"
+               "${FILESDIR}/${PV}-r1-cxxlinkage.patch" \
+               "${FILESDIR}/${PV}-mariadb-dynamic-array.patch" \
+               "${FILESDIR}/${PV}-my_malloc.patch"
 }
 
 multilib_src_configure() {